Author Topic: TE0820-test_board 2021.2 _create_linux_setup.sh fails  (Read 188 times)

ITS

  • Active Member
  • *
  • Posts: 2
TE0820-test_board 2021.2 _create_linux_setup.sh fails
« on: September 22, 2022, 11:58:45 PM »
TE0820-test_board_noprebuilt-vivado_2021.2-build_15_20220912132233.zip
_create_linux_setup.sh
0
54
y
2
...
ERROR: [IP_Flow 19-3478] Validation failed for parameter 'SD0 IO(PSU__SD0__PERIPHERAL__IO)' with value 'EMIO' for BD Cell 'zynq_ultra_ps_e_0'. PARAM PSU__SD0__PERIPHERAL__IO :: MIO 13 .. 16 21 22 is out of range { EMIO,MIO 13 .. 22,MIO 38 .. 48,MIO 64 .. 74 }
ERROR: [IP_Flow 19-3478] Validation failed for parameter 'POW IO(PSU__SD0__GRP_POW__IO)' with value 'EMIO' for BD Cell 'zynq_ultra_ps_e_0'. PARAM PSU__SD0__GRP_POW__IO :: MIO 23 is out of range { EMIO }

same using TE0820-test_board_noprebuilt-vivado_2021.2_withoutvivadopatch-build_11_20220128090819.zip : project OK.
What is "withoutvivadopatch" ?

Tomasz Motylewski IT-Services

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1969
Re: TE0820-test_board 2021.2 _create_linux_setup.sh fails
« Reply #1 on: September 23, 2022, 07:45:20 AM »
Hi,
Without Vivado patch is without Vivado patch (or update) ;-)
https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/vivado-design-tools/2021-2.html
--> Version 21.2.1 update

Unfortunately Xilinx has add accidentally some features from 2022.x ZynqMP IP update to the 2021.2.1 patch... So we have the problem that we can't create board files which are compatible to both version...we have make some general notes here:
https://wiki.trenz-electronic.de/display/PD/Xilinx+Development+Tools#XilinxDevelopmentTools-XilinxSoftware-ProductUpdateReleaseNotesandKnownIssues
https://support.xilinx.com/s/feed/0D54U00005Wbon6SAB?language=en_US
I also ask on Xilinx forum, but never get answers....
https://support.xilinx.com/s/feed/0D54U00005Wbon6SAB?language=en_US

We used new style now because it will be used from Xilinx in the future....

br
John

ITS

  • Active Member
  • *
  • Posts: 2
Re: TE0820-test_board 2021.2 _create_linux_setup.sh fails
« Reply #2 on: September 23, 2022, 10:20:33 AM »
OK, understand now withoutvivadopatch. I will install 2021.2.1 and try again. Actually I wanted to use 2022.1, I will import resulting 2021.2.1 project into 2022.1.
I think it would be a good idea to rename current TE0820-test_board_noprebuilt-vivado_2021.2-build_15_20220912132233.zip to
TE0820-test_board_noprebuilt-vivado_2021.2.1-build_15_20220912132233.zip

This leads to the next question: what about Viado 2022.1 support? I actually wanted to use that.
Now using TE0820-test_board_noprebuilt-vivado_2021.2-build_15_20220912132233.zip

(a)  Start  design with unsupported Vivado Version (beta)

2022.1

  • Info: /tools/Xilinx/PetaLinux/2022.1/tool/settings.sh not found try alterative path /home/tm/petalinux/2021.2/settings.sh
       this should be tools instead of tool
N
54
y
2

Code: [Select]
INFO: [TE_UTIL-2] Following block designs were found:
   te_prj/block_design/zusys_bd.tcl
  ------
INFO: [TE_INIT-8] Found BD-Design:
  TE::BD_TCLNAME:       zusys_bd
  TE::PR_TOPLEVELNAME: zusys_wrapper
  ------
  TE::IS_ZUSYS:        true
INFO: [TE_UTIL-2] Following block designs were found:
   te_prj/block_design/zusys_bd.tcl
  ------
INFO: [TE_BD-0] This block design tcl-file was generate with Trenz Electronic GmbH Board Part:trenz.biz:te0820_2eg_1e:part0:2.0, FPGA: xczu2eg-sfvc784-1-e at 2022-04-26T14:29:48.
INFO: [TE_BD-1] This block design tcl-file was modified by TE-Scripts. Modifications are labelled with comment tag  # #TE_MOD# on the Block-Design tcl-file.

ERROR: [BD 5-104] A block design must be open to run this command. Please create/open a block design.
ERROR: [TE_INIT-146] Script (TE::VIV::import_design) failed: ERROR: [Common 17-39] 'current_bd_design' failed due to earlier errors.
.
ERROR: (TE_INIT-146) Script (TE::VIV::import_design) failed: ERROR: [Common 17-39] 'current_bd_design' failed due to earlier errors.
.
ERROR:(TE) Script (TE::INIT::run_board_selection) failed: .
ERROR:(TE) Script (TE::main) failed: .

Tomasz Motylewski IT-Services

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1969
Re: TE0820-test_board 2021.2 _create_linux_setup.sh fails
« Reply #3 on: September 23, 2022, 10:37:44 AM »
Quote
TE0820-test_board_noprebuilt-vivado_2021.2.1-build_15_20220912132233.zip
theoretically yes, but practical no....it's bug from xilinx. Normally 2021.2.1 must be compatible to 2021.2....xilinx has only one git for board files for 2021.2...
https://github.com/Xilinx/XilinxBoardStore/tree/2021.2/boards/Trenz_Electronic
....
so depending on the user I can never make a correct file for all
....

Quote
This leads to the next question: what about Viado 2022.1 support? I actually wanted to use that.
Now using TE0820-test_board_noprebuilt-vivado_2021.2-build_15_20220912132233.zip

unsupported means unsupported....it can work or not....depending on xilinx changes...next updates of the reference designs comes with 22.2 version of vivado....

What you can do is create this project with 2021.2/2021.2.1 and than open again with 22.1 version and use xilinx upgrade function....if this works depends on xilinx, we can't support this....

Note: Odd Vivado version numbers has mostly new features and more bugs...even numbers are bugfixes...so they are mostly more stable....
br
John






« Last Edit: September 23, 2022, 12:00:02 PM by JH »