Author Topic: sysmon-pl on TE0808 / TE0807  (Read 577 times)

GuinnessTrinker

  • Active Member
  • *
  • Posts: 34
sysmon-pl on TE0808 / TE0807
« on: February 03, 2022, 12:37:17 PM »
We would like to use external muxer to sysmon inside pl.

Usually you connect muxer-output to dedicated pins Vp/Vn.
On Trenz-boards these pins are connected to lowpass-filter (RC) of 100nF / 2* 4.7 k.
At a samplingrate of 200 kHz and 16 external sources you get "nothing" realistic.

How can we fix that?
Using another port (Vaux_6 on bank 47 für example) disables some of external muxer inputs.

At this point of development we must be able to replace TE0807 and TE0808 without modifications on our carrier-board.
(same pins on module-sockets)


Is it possible to order boards without 100nF ?
We tried to remove that with successfull results.


« Last Edit: February 03, 2022, 12:53:07 PM by GuinnessTrinker »

GuinnessTrinker

  • Active Member
  • *
  • Posts: 34
Re: sysmon-pl on TE0808 / TE0807
« Reply #1 on: February 04, 2022, 10:02:39 AM »
solution found  ;)

If you want to use sysmon inside PL together with external MUX, dont use Vp/Vn to connect output of external MUX.
This is because Trenz-Modules have RC-LP connected to this input.

You can use any Vaux instead of Vp/Vn.

When using banks 47, 48 (TE0808) or banks 46, 45 (TE0807) you would face the problem that Vivado GUI does not allow to activate the sequencer and average on some channels.




This is a bug.

You can workaround this by not using Vivado-GUI, but .tcl script to create Vivado projects (my favorite) or activate these channels by SW after building hw-description.

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1956
Re: sysmon-pl on TE0808 / TE0807
« Reply #2 on: February 07, 2022, 06:36:44 AM »
Hi,

good to hear that you has find a solution and thank you for sharing this workaround!

br
John