Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

openOCD for TE0701+TE0720

Started by amb_kosh, January 27, 2015, 01:38:06 PM

Previous topic - Next topic



I would like to debug my application using USB/JTAG under linux (host and target). I've compiled openOCD following as close as possible the instruction on All is fine until I try to connect gdb to openOCD - the log is attached to this posting. Also attached is the openOCD config file. I'm using eclipse + GDB hardware Debugger plugin as the gdb frontend.
I've tried several ways of compiling openOCD (0.7/0.8, libftd2xx/libftdi) but all look more or less the same. The root cause for the failure seems to be:
Error: MEM_AP_CSW 0x2800062, MEM_AP_TAR 0x1e348
Error: Failed to read memory at 0x0001e348

Any ideas welcome

thank you

Antti Lukats

similar problems happen with Xilinx debugger tools also :(

There are specific delays and order of commands that may cause the ARM DAP to behave badly, I have had similar issues this also many many times.

When I did the openOCD testing, then it worked, but it was done on windows host. After that work we have not tried with openOCD any more.

Try to let the zynq to boot from some empty dummy FSBL, that may solve the issue