Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

Flash QSPI TE0820 with 2022.2 tools

Started by Adrien, February 09, 2024, 04:41:23 PM

Previous topic - Next topic


I am trying to flash the QSPI of a TE0820-04-4DE21FA with a carrier board TE0703-06 with 2022.2 Xilinx tools.
So I did _create_win_setup.cmd, generate binaries and tried to flash _binaries_TE0820-04-4DE21FA\boot_linux with _binaries_TE0820-04-4DE21FA\res_elf\fsbl.elf or SDMODE\fsbl_flash.elf with the command `C:\Xilinx\Vitis\2023.2\bin\program_flash -f BOOT.bin -fsbl fsbl_flash.elf -flash_type qspi-x8-dual_parallel -url tcp:localhost:3121` with the Switch S2-1 & S2-2 & S2-3 On and S2-4 Off but nothing works and I have the following:
>> ===== mrd->addr=0xFF5E0204, data=0x00000222 =====
>> BOOT_MODE REG = 0x0222
>> WARNING: [Xicom 50-100] The current boot mode is QSPI32.
>> Flash programming is not supported with the selected boot mode.If flash programming fails, configure device for JTAG boot mode and try again.
>> Downloading FSBL...
>> Running FSBL...
>> ===== mrd->addr=0xFFD80044, data=0x00000000 =====
>> ===== mrd->addr=0xFFD80044, data=0x00000000 =====
>> ...
>> ERROR: [Xicom 50-331] Timed out while waiting for FSBL to complete.
>> Problem in Initializing Hardware
>> Flash programming initialization failed.

I know about using the fsbl_flash to get around this QSPI mode to use JTAG instead but I just don't get how I am supposed to find/create/use it.
There is no zynqmp_fsbl_flash in sw_libs/sw_app/ in zip 2022.2. I tried to generate zynqmp_fsbl with prebuilt 4ev_1e_2gb, use a fsbl_flash from previous version...


here are some information about this topic:

At the end you should change boot mode to JTAG for flash programming, if you want to use newer Vivado version.Workaround with special FSBL seems to work less and less with each newer Version...

So simple install oder Vivado Labtools version (best was 17.2 as long as it now the device and the flash) and try again.
Or change boot mode to JTAG (there are different ways possible, depending on your carrier and CPLD Firmware). ways depends on CPLD Firmware, see CPLD Firmwar update and Variants:

Of course, it is also possible that the FSBL has a problem and simply crashes (FSBL does not match variant or module defective or simply a power problem). But I can't say that with your information yet. You could first boot from the SD card and see if that works.



I happened to have other products from Trenz. I just tried with TE0820-05-4AE81MA REV5 and a carrier TE0703-05 this time and it works, first try. I am still using Xilinx 2022.2 tools on Windows 10 and the switch on the carrier is configured the same. I just did the same, launch _create_win_setup.cmd, create binaries, create zynqmp_fsbl (TE modified) with sw_libs/ and prebuilt .xsa file. I just don't know. If I have time I will test on the previous setup.


different can be QSPI is with our without design...or like I say some other issue.
Try to change boot mode to JTAG only, if it works, than it's problem with AMD software only.

Let me know if you need help again.