Author Topic: TE803 24AA025E48T EEPROM Not Responding  (Read 515 times)

pmorris

  • Active Member
  • *
  • Posts: 1
TE803 24AA025E48T EEPROM Not Responding
« on: March 01, 2022, 05:03:10 PM »
I am testing a number of our units with a batch of TE803 SoMs that have recently been delivered. On our design the first I2C bus from the PS is looped off the SoM (using MIO38 / 39) and connected back to the PLL_SCL/SDA I2C bus. This allows us to write serial numbers etc to the SoM's EEPROM.

I have found that with the first four units I have tested only 2 of them work correctly. On the 2 "faulty" units I can read from the PLL's I2C interface (at address 0x70) but the EEPROM (at address 0x50) does not respond at all. Probing on our carrier board I can see that the I2C transaction is not being acknowledged and hence is failing. I have tried this repeatedly with consistent results. I am currently debugging using Linux and the i2c-tools package.

This seems like a really simple component to have a fault. However it seems it is unlikely to be a problem elsewhere on the I2C bus when I can talk to the PLL reliably. Therefore please could you let me know if the EEPROM is tested at the factory, and whether any similar faults have been reported.

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1970
Re: TE803 24AA025E48T EEPROM Not Responding
« Reply #1 on: March 02, 2022, 03:20:53 PM »
Hi,
do you have our TEBF0808 carrier on place?
If yes, can you check if this works with our prebuilt binaries designs from starterkit:
https://wiki.trenz-electronic.de/display/PD/TE0803+StarterKit
--> https://wiki.trenz-electronic.de/display/PD/TE0803+StarterKit#TE0803StarterKit-Download
--> https://wiki.trenz-electronic.de/display/PD/TE0803+StarterKit#TE0803StarterKit-Launch
You can scan all buses with i2cdetect and you should see both I2C addresses.
Can you explain how you connect I2C --> Did you add Pullups?
PS: I will also answer on your email.
br
John
« Last Edit: March 02, 2022, 03:23:06 PM by JH »