Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

Arrow USB Blaster Driver Issues

Started by jaritter, July 13, 2020, 04:44:52 PM

Previous topic - Next topic


I have been trying to set up my MAX1000 (V2) board to work with the current Quartus Prime Lite (V19.1) install.  Running Windows 10 Pro, it recognizes my Terasic USB Blaster fine but trying driver versions 2.2 and 2.4, I have not been able to get Quartus to recognize the MAX1000 board.  It does show up in USBView, so the USB hub on the motherboard recognizes it.

First question:  Which version of the driver should I be using for Win/10 Pro, MAX1000 V2 and Quartus Prime 19.1?

Second question:  What are the magic incantations necessary to get this working?

I was planning on using the MAX1000 board for a couple of test/support projects (one-off designs so don't want to have to use contract assembly to put down a EQFP or BGA on my own board) so not being able to program the FPGA on the MAX1000 is a deal-killer.



you must install newest drivers (2.4).
Can you run one time the diagnose program(start as admin):

  • -->
Can you send the the console log of this.


I've attached the output from the diagnostic program.  Steps I took so far:

1. Uninstalled the previous version (I think I had last tried loading V2.2)
2. Rebooted.
3. Installed V2.4
4. Rebooted (with the MAX1000 board plugged in)
5. Ran the diagnostic program, saved a screen cap of its output (attached)

It looks like the only complaint is "No programmer hardware found."

But I've run the USB diagnostic before and the MAX1000 is there (just a "Composite USB Device") and disappears if I unplug it.

What's the next step?


can you send the serial number (number on the small white sticker with QR Code) of your MAX1000 to

In the meantime, can you check one time usb properties of the device.
Download MS USB viewer:
Open USB Viewer and connect the MAX1000, you should see a new device, can you tell me what you see in the property window (you can send screenshot it with the email).



Will do, John.  That setup is at home and I'm at a client's site today so I'll send the serial number and usb view info this evening (U.S. Central time).



The serial number is A01738.

The three screen caps below are from USBView.  First, with the MAX1000 board not plugged in.  Second and third are with it plugged in.  I scrolled down in the detail window to show everything, so there are two screen caps in the same condition to show all of the detail window.


I've answered on your email.



I thank you for your analogy. My IT guy has been making good headway on this issue and I have confidence that we will get things smoothed out.



Hello Madhu,
you has also problems with a MAX1000?

Can you send the serial number (number on the small white sticker with QR Code) of your MAX1000 to



I also had driver issues. However, as it turned out, the USB-A to MicroUSB cable was the problem! Switched cables, worked! Just for people who are struggeling, maybe this helps!