Author Topic: TE0803-03 + TEBF0808 Vivado and SDK could not detect MPSOC  (Read 1461 times)


  • Active Member
  • *
  • Posts: 1
I am using TE0803-03 + TEBF0808 ,when I tried to use vivado and sdk to connect the MPSOC, vivado shows:

 [Labtools 27-2269] No devices detected on target localhost:3121/xilinx_tcf/Xilinx/00001b8ea2c701.
Check cable connectivity and that the target board is powered up then
use the disconnect_hw_server and connect_hw_server to re-register this hardware target.

I tried both USB JTAG and J30 JTAG via xilinx platform cable USB II, but failed both.
I read the web pages:
 Zynq MPSoC Debug Troubleshooting
which shows : On Zynq MPSoC JTAG is disabled by default after each power cycle or main reset and only enabled if bootrom does it under software control. If FSBL is not found or the FSBL found detects some error condition, then JTAG may be left disabled, and further debugging is not possible.
the soluton you give is "Select JTAG bootmode. Use known good FSBL that releases JTAG for debug process."  but, where I can find the GOOD FSBL  to releases JTAG?

Are there any hardware or software configuration I need to do first? The trenz wiki docs are confused, and I could not find the correct solution.



  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1987
Re: TE0803-03 + TEBF0808 Vivado and SDK could not detect MPSOC
« Reply #1 on: April 27, 2020, 02:44:30 PM »
documentation of DIP, Buttons, LEDs...:
--> Did you press power button?

Reference Design for TEBF0808 with TE0803 modules:
--> you must select your assembly version, there is more the one TE0803 assembly version available:

Reference design includes also prebuilt files to boot directly from SD.