Trenz Electronic GmbH Support Forum

Trenz Electronic Products => UltraScale => Topic started by: AntoineB on December 18, 2020, 05:44:56 PM

Title: TEBF0808-04A (TE0807-02-4BE21-AK) Displayport issues
Post by: AntoineB on December 18, 2020, 05:44:56 PM
Hi,

I'm trying to build and test a graphic linux image for the TE0807-02-4BE21-AK with Qt and X11 but my displayPort doesn't work.

I've started from the 2019.2 prebuilt starterkit and build an image using petalinux with Qt and X11 packages groups enabled.

After booting the board I got the following issues, do you know how to solve this issue ?

Starting Xserver
Starting Dropbear SSH server: dropbear.

Starting internet superserver: inetd.
Starting syslogd/klogd: done
Starting tcf-agent:
X.Org X Server 1.20.1
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.10.0-327.el7.x86_64 x86_64
Current Operating System: Linux starter-project 4.19.0-xilinx-v2019.2 #1 SMP Fri Dec 18 10:18:54 UTC 2020 aarch64
Kernel command line: console=ttyPS0,115200 earlycon clk_ignore_unused earlyprintk root=/dev/mmcblk1p2 rootfstype=ext4 rw rootwait cma=1024M
Build Date: 24 October 2019  07:22:49AM
 
Current version of pixman: 0.34.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec 18 14:51:39 2020
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
starter-project login: xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

I also get these errors during the boot, not sure if they are relevant or not :

[    3.757840] xilinx-psgtr fd400000.zynqmp_phy: PLL lock time out
[    3.763751] xilinx-psgtr fd400000.zynqmp_phy: Lane:3 type:8 protocol:4 pll_locked:no
[    3.771484] zynqmp-display fd4a0000.zynqmp-display: failed to lock pll
[    3.778019] zynqmp-display: probe of fd4a0000.zynqmp-display failed with error -110
Title: Re: TEBF0808-04A (TE0807-02-4BE21-AK) Displayport issues
Post by: JH on December 18, 2020, 07:09:52 PM
Hi,
did you use our FSBL modification fir SI5345 configuration? Xilinx default FSBL will not initilise SI, so reference clks for the GTR are missing.

Please try out prebuilt binaries of the reference design, this should work.
Starterkit Design includes also FSBL template with our changes which can be load as local repository into Vitis

br
John
Title: Re: TEBF0808-04A (TE0807-02-4BE21-AK) Displayport issues
Post by: AntoineB on December 22, 2020, 10:53:48 AM
Hi John,

Thanks for your answer.
I've changed my FSBL for the prebuilt  one and it worked.