Author Topic: Build error after adding xilffs to BSP of TE0715  (Read 481 times)

mkora

  • Active Member
  • *
  • Posts: 2
Build error after adding xilffs to BSP of TE0715
« on: September 30, 2021, 03:23:31 PM »
Hi all,

I am using TE0715 with carier board TE0701 on vitis 2021.

I am programming in bare metal mode without any OS and I want to be able to write some files in SD card.

Because I had done it before on zedboard, I added xilffs to the BSP and added xilffs to library settings tab of the application and finally included ff.h

When I tey to build the application, it gompiles well but on the linke gives me  undefined reference to error on the first function that I have used from ff.h.

I tried it again with zedboard and it works well, however I can not use it with a platform based on TE0701. I have added the log of the console at end of this post.

Hope someone here can help me to solve this issue.

Best regards,
Mostafa





10:54:45 **** Incremental Build of configuration Debug for project te_sd_tst2 ****

make all

make --no-print-directory pre-build

a9-linaro-pre-build-step

 

make --no-print-directory main-build

Building file: ../src/helloworld.c

Invoking: ARM v7 gcc compiler

arm-none-eabi-gcc -Wall -O0 -g3 -c -fmessage-length=0 -MT"src/helloworld.o" -mcpu=cortex-a9 -mfpu=vfpv3 -mfloat-abi=hard -I/home/osboxes/ws_te_sd/te_sd_pltfrm_base1/export/te_sd_pltfrm_base1/sw/te_sd_pltfrm_base1/standalone_domain/bspinclude/include -MMD -MP -MF"src/helloworld.d" -MT"src/helloworld.o" -o "src/helloworld.o" "../src/helloworld.c"

../src/helloworld.c:150:12: warning: 'ReadFile' defined but not used [-Wunused-function]

 150 | static int ReadFile(char *FileName, u32 DestinationAddress)

   |      ^~~~~~~~

Finished building: ../src/helloworld.c

 

Building file: ../src/platform.c

Invoking: ARM v7 gcc compiler

arm-none-eabi-gcc -Wall -O0 -g3 -c -fmessage-length=0 -MT"src/platform.o" -mcpu=cortex-a9 -mfpu=vfpv3 -mfloat-abi=hard -I/home/osboxes/ws_te_sd/te_sd_pltfrm_base1/export/te_sd_pltfrm_base1/sw/te_sd_pltfrm_base1/standalone_domain/bspinclude/include -MMD -MP -MF"src/platform.d" -MT"src/platform.o" -o "src/platform.o" "../src/platform.c"

Finished building: ../src/platform.c

 

Building target: te_sd_tst2.elf

Invoking: ARM v7 gcc linker

arm-none-eabi-gcc -mcpu=cortex-a9 -mfpu=vfpv3 -mfloat-abi=hard -Wl,-build-id=none -specs=Xilinx.spec -Wl,-T -Wl,../src/lscript.ld -L/home/osboxes/ws_te_sd/te_sd_pltfrm_base1/export/te_sd_pltfrm_base1/sw/te_sd_pltfrm_base1/standalone_domain/bsplib/lib -L"/home/osboxes/ws_te_sd/te_sd_pltfrm_base1/zynq_fsbl/zynq_fsbl_bsp/ps7_cortexa9_0/libsrc/xilffs_v4_5/src" -o "te_sd_tst2.elf" ./src/helloworld.o ./src/platform.o -Wl,--start-group,-lxil,-lgcc,-lc,--end-group -lxilffs -Wl,--start-group,-lxilffs,-lxil,-lgcc,-lc,--end-group

/tools/Xilinx/Vitis/2021.1/gnu/aarch32/lin/gcc-arm-none-eabi/x86_64-oesdk-linux/usr/bin/arm-xilinx-eabi/arm-xilinx-eabi-ld.real: ./src/helloworld.o: in function `SD_Init':

/home/osboxes/ws_te_sd/te_sd_tst2/Debug/../src/helloworld.c:128: undefined reference to `f_mount'



JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1835
Re: Build error after adding xilffs to BSP of TE0715
« Reply #1 on: October 05, 2021, 06:59:06 AM »
Hi,
Quote
Because I had done it before on zedboard,
Also with 21.1?

At the moment we use 2020.2 next version we start to use will be 2021.2, so I can't help much on this question.

Which PS setup did you use?
br
John


mkora

  • Active Member
  • *
  • Posts: 2
Re: Build error after adding xilffs to BSP of TE0715
« Reply #2 on: October 05, 2021, 10:12:42 AM »
Thanks for your reply. Do you think if I cahnge the vivado version solve the problem?

The system in total is just a Zynq without any PL and I made a platform based on the xsa file that was generated in vivado.

I used the TE0715 BSP for making the vivado project.

In vitis, I have made stand alone application based on that platform. The only thing that is added to the default settings is the xilffs

that I have added to the BSP of the project.

br,
Mostafa


JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1835
Re: Build error after adding xilffs to BSP of TE0715
« Reply #3 on: October 05, 2021, 10:48:10 AM »
Hi,
can you try out our 2020.2 reference design:
https://wiki.trenz-electronic.de/display/PD/TE0715+Test+Board

we use xilffs there also for second FSBL (--> there are 3 different bsp, one generated by platform for fsbl, one standalone for apps and one for second fsbl for flash programming (which needs also xilffs)).

br
John