Recent Posts

Pages: [1] 2 3 ... 10
UltraScale / Re: Ethernet and uboot on TEBF0808
« Last post by Oleksandr Kiyenko on October 19, 2018, 10:26:34 AM »

If you able to ping your PC from u-boot it means that network is working. Think that you can't ping u-boot from PC because u-boot is not OS, and have no permanent ICMP service. Think that u-boot
process ICMP packets only when it waits for a response for its own ping request, but not all the time.

Best regards
Oleksandr Kiyenko
UltraScale / Re: Ethernet and uboot on TEBF0808
« Last post by Chris12 on October 19, 2018, 10:02:42 AM »
I'm not using Petalinux: I just grabbed the BOOT.bin file from the starterkit, that's all.
IP address is statically defined in uboot (ipaddr env variable), as well as netmask and gateway ip.

When booting VxWorks kernel (from sdcard), it works: I can ping in both directions with same ipaddr, gateway, netmask than uboot
This means my laptop config is ok and the firewall is not blocking the connection

So my guess is that something must be wrong in the uboot config, but I can't figure out what it is.

UltraScale / Re: Ethernet and uboot on TEBF0808
« Last post by JH on October 18, 2018, 08:09:58 PM »
uboot is default configuration from petalinux. Firewall of your PC is deactivated if you test direct connection? Can you try out without firewall (disconnect laptop from "real network" before you deactivate the firewall).

Does Uboot get an IP from your rooter if you connect ETH to your normal network. IF you use also our petalinux, does ETH works there?

Which Starterkit design version did you download? From 2018.2?

UltraScale / Re: PL clock failure
« Last post by JH on October 18, 2018, 07:56:15 PM »
Hi Charlie,

normally JTAG Debug Interface should not have such a affect on PS-PL CLK, very strange.

We know from an interaction of JTAG Debugger interface with Linux and UART since Vivado 2017.4, but this was solved if we disable Frequenzscalling on Linux:
But in this case it was not permanent.

Can you try out one time the prebuild files from the reference design please? Docu + Download:

Reference Design used VIO instead of ILA.
Can you send me result of this test.

UltraScale / Ethernet and uboot on TEBF0808
« Last post by Chris12 on October 18, 2018, 02:06:27 PM »
I'm trying to bring up my brand new MPSoC module.
My goal is to have uboot on SDCard, then load a VxWorks kernel through TFTP.

But I'm having troubles with Ethernet and UBoot.
i'm using the boot.bin image from the starter kit (StarterKit\prebuilt\boot_images\6eg_1ee_sk\u-boot)

Once uboot is started, ping my laptop from uboot, but pinging uboot from my laptop fails.
I need to mention that it works fine with another EVM I have, so it's not a problem from my laptop.
network mask is same.

I'm using a dlink usb to ethernet adapter between the laptop and the board.


UltraScale / PL clock failure
« Last post by charlie5902 on October 17, 2018, 05:36:50 PM »

So I have been working with TEBF0808-04A carrier and TE0803 module for about a month now and having great success developing my Vivado project for our application.
Yesterday, I ran into a situation where it appears the PL clock is no longer functional.
I don't know if it is a coincidence, but the failure occurred at the time when I lowered the JTAG Clock frequency to accommodate an ILA being clocked at a low frequency for debug.
I am now no longer able to communicate with PL components over the AXI bus, software crashes with any PL AXI slave access and my ILAs are not showing up as present after initializing the psu and a hardware refresh. I have rebuilt the project and tried other projects that used to work OK, power cycled the board, my laptop, etc. Problem still persists.
All of this is consistent with PL clock not running.

Is there any way that lowering the JTAG Clock frequency could have cause this kind of issue.

Any thoughts on potential recovery methods I could try?

Thanks for any help.

Trenz Electronic FPGA Modules / Re: Used pins HP for modules Kintex serie 7
« Last post by JH on October 16, 2018, 03:42:44 PM »
we have currently only two  7 series  Kintex boards:
  • TE0741 module without usable HP banks.
  • TEF1001 PCIe Card with FMC but on FMC are only HR available. HP are used for DDR
Is UltraScale also an option for you?
If yes, we have an UltraScale Kintex module with HP banks available:br
Trenz Electronic FPGA Modules / Used pins HP for modules Kintex serie 7
« Last post by acmmmm on October 16, 2018, 11:34:49 AM »
Hi everyone, i need used HP pins of Kintex 7. Is there a Kintex module that uses these pins?

UltraScale / Re: Bank supply voltages
« Last post by dnestler on October 08, 2018, 02:03:39 PM »
Excellent answer.  Thank you, John
UltraScale / Re: Bank supply voltages
« Last post by JH on October 08, 2018, 12:35:03 PM »
Hi David,

1.8V is the only available 1.8V power supply on the module and is used for different device:
It's used for PS, DDR, SI5338, ETH PHY, USB PHY...

B2B connector 2amps max rating is for 2 adjacent pins. 1.8V B2B output is only connected to one pins, so it's appr. max 1 amp or a little less.

So use external 1.8V power supply for the banks and the 1.8V output to enable the this power supply, if you are not sure, that's the current is enough for your periphery.


Pages: [1] 2 3 ... 10