News:

Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

Recent posts

#1
UltraScale / Re: TE0820 -05-2AI21MA and TE0...
Last post by JH - May 24, 2024, 11:15:46 AM
Hi,
you can ignore both messages. I don't know why the tool think it's a newer one available, but local one is the correct one for this reference design
 
 We update this board files only with newer vivado version and sometimes they are not backward compatible.
 In case of local repository, which will be set via trenz scripts for this project, you can also install/copy it into your vivado version(see point 3 or 4):
https://wiki.trenz-electronic.de/display/PD/Installation


Regarding board interface. We didn't add board interfaces for the module, we add only basic PS configuration(see board automation, which will be done automatically on the reference design), which is also used on the reference design. PL design depends mostly on the carrier and customer design and so it makes not really sense to define pl interfaces.

br
John
#2
UltraScale / TE0820 -05-2AI21MA and TE0701-...
Last post by for_those_about_to_code - May 17, 2024, 04:30:58 PM
Hello,

First question on this board.

I have the above pieces of Hardware and I am working through the "Test Board" tutorial (2022.2 version).

I have ran _create_linux_setup.sh (Ubuntu 20.04), selected '0' and then '107' for the corresponding component.

I notices that I get the following couple of lines:

WARNING: [Board 49-151] The current board 'trenz.biz::te0820_2cg_1i:2.0' is from a local repo. The vivado install has a corresponding board with version greater than or equal to the local repo board. Please use boards from vivado install to avoid any upgrade/migrate issues

and

INFO: [Ipptcl 7-1463] No Compatible Board Interface found. Board Tab not created in customize GUI


A couple of questions...

1) How do I use the Installed version rather than the local repo version? 
2) Why do I get the "No Compatible Board Interface..." message?  As far as I can see I am selecting the correct device?

Thanks in advanced.
#3
Trenz Electronic FPGA Modules / Re: TE0710 red SysLed flashing...
Last post by sjoshi - May 17, 2024, 01:39:30 PM
Me again. I have found the issue. Turns out that the design was done assuming that the XMOD will be connected upside down, meaning the odd and even pins were swapped. The second issue while using the TE0790 was the DIP switch 4. This is documented in the TE0706 documentation which was used as a reference design so it was easy to figure out.

Thanks for confirming that the Lattice FPGA has no role other than that what we had assumed.
#4
Trenz Electronic FPGA Modules / Re: TE0710 red SysLed flashing...
Last post by sjoshi - May 17, 2024, 12:50:59 PM
Hi,

I have tried connecting to the board by swapping TDI and TDO but I still get an error message saying that "No devices detected on target".

We are connecting a TE0790 to the carrier board. Are there any other configuration pins I might be missing?
#5
Trenz Electronic FPGA Modules / Re: TE0710 red SysLed flashing...
Last post by JH - May 17, 2024, 10:35:55 AM
Hi,
JTAGSEL bin you can switch between Lattice CPLD and AMD FPGA. JTAG SEL=0 is FPGA(JTAG will forwarded through the CPLD to the FPGA). In case you use JTAGSEL=1, you should see unknown device normaly on vivado HW Manager.

Which programmer did you use on your carrier board?

Check also TDI/TDO, maybe they are swapped in your design?



BOOTMODE or NOSEQ are optional for TE0710 with native FPGA on both available firmwares and are no matter for JTAG:
https://wiki.trenz-electronic.de/display/PD/TE0710+CPLD
or older version for modules which was delivered before feb 2024:
https://shop.trenz-electronic.de/en/Download/?path=Trenz_Electronic/Modules_and_Module_Carriers/4x5/TE0710/REV03/Firmware/archive

br
John
#6
Trenz Electronic FPGA Modules / Re: TE0710 red SysLed flashing...
Last post by sjoshi - May 16, 2024, 03:50:36 PM
I can program the module from a TE0705 board. When I plug the module in our carrier board and pull SC_nRST and EN1 high, the module configures itself from memory and my blinker code works. We seem to be missing JTAG access from our carrier board although I have read on the forum that the JTAG signals are simply patched through. JTAGSEL = 0 also seems to be the suggested setting.
#7
UltraScale / TEF1002-02 with TE0820-05
Last post by harrx - May 16, 2024, 02:31:25 PM
Hello,

I am trying to work with the PCIe Carrier board -> TEF1002 with the TE0820 module. I am stuck at the very begining as the module is not recognized by Vivado Hardware Manager. It sees the Carrier board, but says "No devices connected to the target." I used both the Jtag/ uart and the Xilinx programmer methods.
I see 2 power supply lights on the carrier board and one blinking green light on the Module FPGA, but no Jtag connection. 

I tried the TE0820 module with a custom Carrier Board, and it was detected fine as "xczu3" by Vivado H/W Manager.

Is there any Jumper setting which needs to be taken care of for the Jtag connection (I am using the default) or does it look like a connection problem. How to move forward from here.
#8
CYC1000 community projects / Re: I present a comunity of IN...
Last post by Subcritical - May 16, 2024, 02:26:37 PM
David Carrion create the multicore Bytednia, you can see a cold boot.
Rasberry Pi plus CYC1000.

#9
Arrow USB Programmer2 / Step-by-step videos solving th...
Last post by Subcritical - May 16, 2024, 12:25:51 PM
We have tried to reproduce all the errors and create a sequence of videos, including the one that was most difficult to watch because the arrow blaster recording failed in a Windows developer. The solution was so simple that it was precisely the most difficult error of all.

When you move the QUARTUS II to another folder, the arrow blaster stops starting correctly.

Mainly because the Windows service looks for the enablement of the service in the path that is saved in the Windows registry.

This mistake, such a simple thing, threw us in the development group.

- Spanish -
#10
Trenz Electronic FPGA Modules / TE0710 red SysLed flashing on ...
Last post by sjoshi - May 16, 2024, 12:12:51 PM
We are working with a custom carrier board which should host a TE0710 module. On powering up the board and module, we have noticed that the red SysLED keeps flashing continuously.

It appears that there is a design flaw where we have overlooked the SC_nRST, EN1, BOOTMODE and NOSEQ inputs to the module. The EN1 and SC_nRST pins can still be used, however BOOTMODE and NOSEQ are left unconnected in the design. On pulling SC_nRST high, the red SysLed stops flashing.

Vivado cannot detect the target even if EN1 is high or low. I am afraid that BOOTMODE or NOSEQ play a crucial role in initializing the Artix 7. We are currently using a TE0790 as the programmer. The JTAG pins have been connected in a scheme similar to that used on the TE0706.

Is there a way we can still rescue the board? Can we use a custom firmware for the onboard Lattice which can overlook the NOSEQ and BOOTMODE pin states and let us access the FPGA over JTAG? The JTAGSEL signal is pulled low.