Author Topic: TE0803 Fsbl Called Repeatedly  (Read 175 times)

kjl

  • Active Member
  • *
  • Posts: 7
TE0803 Fsbl Called Repeatedly
« on: September 13, 2018, 03:06:42 PM »
I am facing this issue currently and wanted to ask if anyone saw something like this before?
Basically, after building and successfully packaging BOOT.BIN, and placing it into a SD Card with image.ub, the boot looks like that:
Code: [Select]
Xilinx Zynq MP First Stage Boot Loader (TE modified)
Release 2017.4   May 17 2018  -  11:11:55

--------------------------------------------------------------------------------
TE0803 Board Initialisation
SI5338 Init Function
Si5338 Rev 1 Initialization             Done
PCIe Reset Complete
--------------------------------------------------------------------------------
NOTICE:  ATF running on XCZU3EG/silicon v4/RTL5.1 at 0xfffea000, with PMU firmware
NOTICE:  BL31: Secure code at 0x0
NOTICE:  BL31: Non secure code at 0x8000000
NOTICE:  BL31: v1.3(release):47af34b
NOTICE:  BL31: Built : 19:49:24, Sep 12 2018
Xilinx Zynq MP First Stage Boot Loader (TE modified)
Release 2017.4   May 17 2018  -  11:11:55

--------------------------------------------------------------------------------
TE0803 Board Initialisation
SI5338 Init Function
Si5338 Rev 1 Initialization             Done
PCIe Reset Complete
--------------------------------------------------------------------------------
NOTICE:  ATF running on XCZU3EG/silicon v4/RTL5.1 at 0xfffea000, with PMU firmware
NOTICE:  BL31: Secure code at 0x0
NOTICE:  BL31: Non secure code at 0x8000000
NOTICE:  BL31: v1.3(release):47af34b
NOTICE:  BL31: Built : 19:49:24, Sep 12 2018
Xilinx Zynq MP First Stage Boot Loader (TE modified)
Release 2017.4   May 17 2018  -  11:11:55

--------------------------------------------------------------------------------
TE0803 Board Initialisation
SI5338 Init Function
Si5338 Rev 1 Initialization             Done
PCIe Reset Complete
--------------------------------------------------------------------------------
NOTICE:  ATF running on XCZU3EG/silicon v4/RTL5.1 at 0xfffea000, with PMU firmware
NOTICE:  BL31: Secure code at 0x0
NOTICE:  BL31: Non secure code at 0x8000000
NOTICE:  BL31: v1.3(release):47af34b
NOTICE:  BL31: Built : 19:49:24, Sep 12 2018
So it seems like Fsbl keeps restarting non-stop after it is done. Also, the on-board LED signalling PL configuration keeps turning on and off for every round of fsbl (not sure if that means it keeps trying to get configured?)

Thanks!

JH

  • Hero Member
  • *****
  • Posts: 641
Re: TE0803 Fsbl Called Repeatedly
« Reply #1 on: September 13, 2018, 03:13:33 PM »
Hi,
yes it's reboot.  after  the "----------------" line normally application will be started.
Which application did you add?
Your application is generated with the same version as the vivado project?
We have prebuilt Boot.bin and image.ub or in case you want use Linux, boot.bin with Hello TE0803 on our reference design (newest version is 2018.2).
Does this work?
br
John

kjl

  • Active Member
  • *
  • Posts: 7
Re: TE0803 Fsbl Called Repeatedly
« Reply #2 on: September 13, 2018, 08:27:31 PM »
I see, yes the prebuilt BOOT.BIN and image.ub works. Sorry for not clarifying that but this is running on a modified vivado project. As it turns out, there were a few issues with the vivado project:
1. UART0 was not enabled.
2. MIO configurations were done incorrectly.

I will update if there is any more useful progressions  :)