Author Topic: PL Power Status OFF, cannot connect PL TAP  (Read 19108 times)

gawrcool

  • Active Member
  • *
  • Posts: 11
PL Power Status OFF, cannot connect PL TAP
« on: September 10, 2018, 02:20:42 PM »
Hi,

I'm using Vivado 2018.2.1 64bits on Win10 system. I use TE0803-01-03EG-1EB on the UltraITX+ baseboard.
I use the TE0803-Starterkit-vivado_2018.2-build_02_20180814103204

The synthesis and implement process are successful. But when I use "Open Hardware Manager", I get the following:

[Labtools 27-3421] xczu3_0 PL Power Status OFF, cannot connect PL TAP.  Check POR_B signal.

I've searched over the web for this but nothing was relevant for me (in my opinion).
I've verified that the "design_basic_settings.cmd" is well modified for the board:
@set PARTNUMBER=8

Can you help me?

Regards,


 

gawrcool

  • Active Member
  • *
  • Posts: 11
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #1 on: September 11, 2018, 11:15:39 AM »
Solved, sorry, don't know how  ;D

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1997
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #2 on: September 11, 2018, 12:21:06 PM »
Hi,
ok, good that it works again.
Which carrier did you use?
This message is independents from reference design. It's a new message since vivado 2018.1 or 2018.2 vivado read back some power control register from the ZynqMP, maybe PL part was not powered on --> PL part on can be disabled on the module.
There are also power save mechanism on ZynqMP itself possible.
See:
page 29 figure 1-2 Power Domains and Islands

br
John

gawrcool

  • Active Member
  • *
  • Posts: 11
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #3 on: September 11, 2018, 01:22:20 PM »
I use the TEBF0808-04
Thank you for the advice

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1997
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #4 on: September 11, 2018, 01:59:43 PM »
Hi,
stand-alone? Did you use ATX power supply or external 12V. I think 12V only or?  If so, I think you has not powered on the module at the first time. In this case, module is not completely powered of, if you did not press the power button. CPLD Firmware was manly made for ATX power supply. On stand-alone usage it will be powered PS part at the moment --> PS has power, PL not.  I will try to develop a Firmware which will prevent this state, but I can't tell you a timeline at the moment.   
br
John

gawrcool

  • Active Member
  • *
  • Posts: 11
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #5 on: September 11, 2018, 02:50:17 PM »
Ty John,
I use stand alone with the little jack 12V (not the big ATX connector).
Indeed, I've just tested. After power on, I've to push on the power PB S1 in order to be able to download firmware in the PL.

Kayasdev

  • Active Member
  • *
  • Posts: 5
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #6 on: May 07, 2019, 08:57:02 AM »
Hello

I am facing the same issue with trenz TE0820-02 Board. Is there a way to recovery it.


Thanks
Kayas

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1997
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #7 on: May 07, 2019, 02:52:40 PM »
Hi,
you mean
Quote
[Labtools 27-3421] xczu3_0 PL Power Status OFF, cannot connect PL TAP.  Check POR_B signal.
?
This happens if ZynqMP is not configured and Boot Mode is unequal JTAG. In this case this warning can be ignored.
Note: PS will be not initialised with bitstream!
br
John

Kayasdev

  • Active Member
  • *
  • Posts: 5
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #8 on: May 07, 2019, 07:23:06 PM »
Hi,
Thanks for reply.

Can this be a reason for my board unable to boot. It boots till FSBL. FSBL log print I get 4 times as shown below.

Xilinx Zynq MP First Stage Boot Loader
Release 2018.2 Apr 20 2019 - 11:34:42

--------------------------------------------------------------------------------
TE0820 Board Initialization

--------------------------------------------------------------------------------

Thanks,
Kayas

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1997
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #9 on: May 08, 2019, 08:49:27 AM »
Hi,
your board seems to boot, but it stops on FSBL or PMU or when he try to start application.

Which carrier did you use? Wich external power supply? some current limit?

What's happens if you use our current reference design? --> prebuilts Boot.bin (barmetal Hello TE0820 and Uboot for linux available) and imag.ub (for linux)
Which assembly version did you use? Did you select the correct one?

If this also not works, can you create the FSBL with Debug Flags?


br
John

Kayasdev

  • Active Member
  • *
  • Posts: 5
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #10 on: May 08, 2019, 11:50:01 AM »
Hi,

I tried to boot manually from XSCT it boots properly. the only problem comes when booted from qspi flash.
What can be the issue.

Note: same build was used both cases.


Thanks & Regards
Kayas

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1997
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #11 on: May 08, 2019, 12:11:55 PM »
Hi,

Which carrier did you use? Which external power supply? Some current limit?
Which FSBL?

br
John

Kayasdev

  • Active Member
  • *
  • Posts: 5
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #12 on: May 08, 2019, 12:34:09 PM »
Hi,


Which carrier did you use?
-> e352230-aew04
(printed behind carrier board)

Which external power supply?
-> V-TAC
-> 12v 2.5A

 Some current limit?
-> nothing i am aware of

FSBL build by us.
« Last Edit: May 08, 2019, 12:46:03 PM by Kayasdev »

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1997
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #13 on: May 08, 2019, 12:55:48 PM »
Hi,
"e352230-aew04" what's that?  It isn't one from our carrier.  There should be something with TE0701-.., TE0703-...TE0705-..TE0706 and a white sticker with QR code and number, in case it's on of our carrier.
Do you have a link where you has order this carrier?

What's happens when you use our prebuilt Boot.bin of the reference design? --> But I need to now which carrier you used, it depends on the carrier if it works or not. But you can try out one time

br
John

Kayasdev

  • Active Member
  • *
  • Posts: 5
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #14 on: May 09, 2019, 08:51:33 AM »
Hi,
 
 Sorry it turns out to be a customized board.

What can be the issue?


Regards,
Kayas
 

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1997
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #15 on: May 09, 2019, 08:56:38 AM »
Hi,
I need more information over over custom board. Can you send me the schematics? B2B part is at the moment the most interesting part. Send it to support@trenz-electronic.de
Do you have one of our carrier  boards as reference to test the module itself with our reference design? -->Depending on your custom board changes, maybe the reference design starts also there, did you test it?

br
John

markiz

  • Active Member
  • *
  • Posts: 3
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #16 on: December 21, 2022, 11:29:24 AM »
Hi,

was anybody able to find the reason for this error?

Kind regards.

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1997
Re: PL Power Status OFF, cannot connect PL TAP
« Reply #17 on: February 03, 2023, 02:24:20 PM »
Depends on the boot mode. If you has JTAG only boot mode and you power on, than it can be a problem on power supply. In case you has a other boot mode and system try to boot without access than it's mostly wrong message from Vivado.
br
John