Author Topic: TE0720 will not start and LED D5 keep blinking  (Read 672 times)

skaug1

  • Active Member
  • *
  • Posts: 2
TE0720 will not start and LED D5 keep blinking
« on: August 06, 2018, 05:52:55 PM »
Hi,
I'm trying to use a TE0720-03-2IFC3 module on a TE0701-06 carrier board but LED D5(the red one) keeps blinking.
As I turn on the power LED D4 (Done) turns on for less than a second before it turns off again and D5 starts blinking.
I've previously used the carrier board with a TE0715 module without problems.
As the CPLD documentation for the TE7020 is not available I do not know what the blinking LED means, but I guess it's a power error.
What does the error mean, and any idea how to fix this?

best regards
Atle

JH

  • Hero Member
  • *****
  • Posts: 922
Re: TE0720 will not start and LED D5 keep blinking
« Reply #1 on: August 07, 2018, 12:49:47 PM »
Hi,

sorry CPLD description is on the todo list.

But we have older documentations:
GLED1(D2): What does this LED? On or OF
RLED2(D5): Blinking with 50/50 duty cycle? Or 1/8 on and 7/8 OFF?
GLED3(D4): OFF means FPGA part is programmed (Done Pin)

LED Location on the TE0720:Do you see the SoC over the Vivado HW Manager?
br
John

skaug1

  • Active Member
  • *
  • Posts: 2
Re: TE0720 will not start and LED D5 keep blinking
« Reply #2 on: August 07, 2018, 04:58:29 PM »
Hello John,
LED D2 and D4 are off, LED D5 is blinking at 50/50 duty cycle at approximately 4 Hz and today the SoC is visible in the Vivado HW manager.
The SoC was not visible yesterday, but a reboot might have fixed this issue.

I inserted an empty SD card which led to D5 blinking at a 50/50 duty cycle at approximately 1 Hz, D2 is off and D4 is on.
This seems to be correct based on LED status code 3 and 4 in the document

So it seems all is good and that the flashing red light did not mean there was an error.
Thank you for your help.

best regards
Atle