Community > MAX1000 community projects

DEMO MAX1000: Implementation of the soft core "NiosII"

(1/2) > >>

MAX1000: Implementation of soft core "NiosII" from Intel FPGA

The guide is the perfect starting point for first time implementing a soft core into an FPGA and program this core with standard ucontroller language C.
It will show you how easy it is to run a soft core in a MAX10 FPGA.

PS: The used USB Blaster programming tool and driver, is licensed by Arrow Electronics and in combination Trenz Electronic products. It is not allowed to use this driver/IP for own products/purposes. Please read the Arrow license agreement carefully.

Please download the project here:

I'm having some troubles with MAX1000 and NiosII.
I noticed that touching the board or plastic headers shell causes resets both in demo at startup (everytime) and in some of my projects (rarely).

I followed your guide, with the only difference that I added SDRAM support instead of On-Chip RAM because memory was not enough for my pourposes. At first, for some weeks, I had no problems. Now I have the board continuously resetting after loading my code from Eclipse.
I also tried with an external pullup on reset pin or moving the reset on another GPIO. In second case execution time is longer but hangs anyway after a while (5 ~ 6 s).

I can't get any info from the debugger, maybe because I'm looking in the wrong place.

Thank you for any info.


Thank you for this guide.

I am trying to reproduce this with my TEI0001 board on Windows 10 Home laptop. I understand there are couple of mistakes, like pll_locked shall be pll_locked_conduit and that the text instructions on how to interconnect IPs in Quartus do not fully correspond with the screenshots. However, I was able to complete Quartus piece of it and upload to the FPGA board.
Then I continued with Eclipse portion of it and failed on the very last step of downloading  the code into the memory of the MAX10.
I tried Quartus 17.0 and 18.1, the same error, tried Arrow USB Programmer 2.3 and 2.4, no luck. Also followed some hints I found on Internet, but it does not work. I do not know what is the cause, if a sort of incompatibility of Arrow USB with Qaurtus/Eclipse or something else, like a wrong IPs interconnect or something.

I do not have any other board I could try with. Also do not have any other programmer, only TEI0001 board.

I am attaching screenshots of Eclipse download error,  screenshots of Target Connection and System ID pull.

Any help is appreciated.

Thomas D:

--- Quote from: Vlad on October 24, 2020, 09:37:20 AM ---Thank you for this guide.

--- End quote ---
Which project/guide are you talking about exactly? I can see several projects in the link mentioned in the first post of PowerUser.

--- Quote from: Vlad on October 24, 2020, 09:37:20 AM ---I am attaching screenshots of Eclipse download error,  screenshots of Target Connection and System ID pull.

--- End quote ---
It seems that the screenshots are missing in your post. I can't see them.


Hi Thomas,

I am referring to this:
MAX1000 Nios II Core

I attached screenshots as attachments and they are waiting for an approval from administrator.
I guess a direct insertion of an image is not possible. I am new to this forum, when I click Insert Image button I just get this .



[0] Message Index

[#] Next page

Go to full version