Open Source > Open source hardware

Wifi Dongle on ZynqBerry

(1/2) > >>

bentho:
I'm trying to connect to Wifi using a USB dongle on ZynqBerry.
The dongle is a D-Link DWA131 using a Realtek 802.11n chip. I've used it with success on a Raspberry Pi.
How to set up Petalinux to support a Wifi dongle?
I found this link--> http://www.wiki.xilinx.com/Zynq+SDIO+WiFi
I believe I've managed to handle those settings using "petalinux-config -c kernel" command.
But when I put in the adapter after booting the new image, it is not recognized as a Wifi adapter, just a high speed device.
Plus, I have no access to command "iwconfig".
Did anyone of you here try a dongle on ZynqBerry or any other board for that matter?
Any kind of hint is most appreciated :)

Regards
Benny

JH:
Hi,
sorry we did not test any  WiFi dongle.
Are the ath6kl_sdio.ko drivers installed? Can you check this?

br
John

bentho:
Thank you John,

I went to root and then searched for this file that you specified.

cd /
find -name ath6kl_sdio.ko

This file was not found on my Petalinux system.
As for reference, I tried the same search on my Ubuntu machine and it was found.

Best regards
Benny

JH:
Hi,
check petalinux kernel config for this setting:

--- Quote ----> Networking support (CONFIG_NET [=y])
 -> Wireless (CONFIG_WIRELESS [=y])
  -> cfg80211 (CONFIG_CFG80211 [=y])
-> Device Drivers
 -> Generic Driver Options
  -> Userspace firmware loading support (CONFIG_FW_LOADER [=y])
   -> Include in-kernel firmware blobs in kernel binary (CONFIG_FIRMWARE_IN_KERNEL [=n])
 -> Network device support (CONFIG_NETDEVICES [=y])
  -> Wireless LAN (CONFIG_WLAN [=y])
   -> Atheros Wireless Cards (CONFIG_ATH_COMMON [=y])
    -> Atheros mobile chipsets support (CONFIG_ATH6KL [=y])
     -> Atheros ath6kl SDIO support (CONFIG_ATH6KL_SDIO [=m])
--- End quote ---

petalinux-config -c kernel
 -on menu search with "Shift+/" for the config name for example "CONFIG_FW_LOADER"

br
John

bentho:
Hi John,

I think maybe we misunderstood each other. I am not connecting an SDIO adapter, it is a USB dongle.
I was looking into the settings used for SDIO that I found online to be used as guidance.
Anyway, I found out that the D-Link DWA-131 USB dongle is using a chipset called RTL8192CU from Realtek.
It is necessary to know what chipset is used and it can in some cases even be different for different hw versions of dongle :)

Now at least I can get the system to recognize the RTL8192CU device. Here is what I did. In the following menu selection of kernel configuration,
->Device drivers ->Network device support ->Wireless LAN -> Realtek rtlwifi family of devices
I enabled [M] on all devices, including Realtek RTL8192CU/RTL88CU USB Wireless Network Adapters

I now get the following response at console when I plug in the dongle,

root@plnx_arm:~# usb 1-1.5: new high-speed USB device number 4 using ci_hdrc
rtl8192cu: Chip version 0x11
rtl8192cu: Board Type 0
rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
usb 1-1.5: Direct firmware load for rtlwifi/rtl8192cufw_TMSC.bin failed with error -2
usbcore: registered new interface driver rtl8192cu
usb 1-1.5: Direct firmware load for rtlwifi/rtl8192cufw.bin failed with error -2
rtlwifi: Loading alternative firmware rtlwifi/rtl8192cufw.bin
rtlwifi: Selected firmware is not available

Feeling I am getting close but it is still not working.
Best regards
Benny

Navigation

[0] Message Index

[#] Next page

Go to full version