Author Topic: Digilent Z-010 Zync Board  (Read 8354 times)

industrialist

  • Active Member
  • *
  • Posts: 3
Digilent Z-010 Zync Board
« on: May 02, 2014, 08:30:43 AM »
Hi,
I bought a Digilent ZYBO Zync - 7000 Board, with the part no Zynq-7000 XC7Z010. This is a strip-down Version of the newer Zynq-7002.
I bought it with a voucher for the Vivado Suite.
But in the Vivado-Suite, there is no Zynq-7000 XC7Z010 to select. Only the newer versions. Using ther newer versions will fail to program the board, with the error "wrong or incompatible bitstream"
On the Digilent web site, there is an XML-file with the board part description. But I see no instructions how to load the file. It seems also incomplete.

What can I do to get the board known to the Vivando Suite?
thx hs

Oleksandr Kiyenko

  • Sr. Member
  • ****
  • Posts: 408
Re: Digilent Z-010 Zync Board
« Reply #1 on: May 02, 2014, 09:36:37 AM »
Hi,
I see xc7z010clg400-1 in Vivado 2013.4 and 2014.1

Best regards
Oleksandr Kiyenko

industrialist

  • Active Member
  • *
  • Posts: 3
Re: Digilent Z-010 Zync Board
« Reply #2 on: May 02, 2014, 09:41:29 AM »
Hi,
is that the right one? On the Web Site, it says the board is " xc7z010clg400-C". I'll give it a try

thx for the fast answer
hs

industrialist

  • Active Member
  • *
  • Posts: 3
Re: Digilent Z-010 Zync Board
« Reply #3 on: May 02, 2014, 02:12:39 PM »

Hi Oleksandr,
thanks for the reply. I choose the part as described. But:

I am doing the standard "Hello World" application (as presented by XILINX on Youtube)
when I add the ZYNQ processing system IP, the "optimize" function does not work. No presets are assigned.
It looks like, it needs a board XPS description, that the part description does not deliver. As a result, no ports are mapped-

As a result, when I generate the bitsream, it throws the error:
" [Drc 23-20] Rule violation (NSTD-1) Unspecified I/O Standard - 32 out of 162 logical ports use I/O standard (IOSTANDARD) value 'DEFAULT', instead of a user assigned specific value. This may cause I/O..., use this command: set_property SEVERITY {Warning} [get_drc_checks NSTD-1].  ...

But issuing the tcl commands does not help either.

Pardon my questions, I am a real newbie here.
« Last Edit: May 02, 2014, 02:14:35 PM by industrialist »

Oleksandr Kiyenko

  • Sr. Member
  • ****
  • Posts: 408
Re: Digilent Z-010 Zync Board
« Reply #4 on: May 05, 2014, 08:41:07 AM »
Hi,

After you add ZYNQ Processing system, try to click on created block and click "Import XPS Settings" on top. And import XML file from hw\lib\xml of reference project.

Best regards
Oleksandr Kiyenko