Author Topic: Eddy 2.5 problem with debug console  (Read 8102 times)

kaml

  • Active Member
  • *
  • Posts: 2
Eddy 2.5 problem with debug console
« on: April 11, 2014, 07:41:21 AM »
Hello

How to enable console input in Eddy 2.5 board?
Uncommenting
Code: [Select]
ttyS0::respawn:/sbin/getty -L ttyS0 115200 vt100
in /etc/inittab only shows "Welcome to the Eddy development environment." in console, but i cannot login.
DBGU uart works  great in u-boot but on linux doesn't.

Regards
kaml
« Last Edit: April 11, 2014, 09:45:12 AM by Hengist »

Horsa

  • Full Member
  • ***
  • Posts: 145
  • Trenz Electronic GmbH
    • Trenz Electronic GmbH
Re: Eddy 2.5 problem with debug console
« Reply #1 on: April 15, 2014, 02:03:25 PM »
Hello kaml,
you did not describe completely your system set-up.

We assume you are using an Eddy-CPU v2.5 plugged on a Eddy-DK v2.1 development board.
There are no command to enable the console port of Eddy-DK 2.1 with Eddy-CPU v2.5.
Simply plug the DE-09 connector to the console port, then use it.
By the way, users cannot log in from the debugging port.
Use telnet to connect to Eddy and login.

Cheers,
 Horsa

kaml

  • Active Member
  • *
  • Posts: 2
Re: Eddy 2.5 problem with debug console
« Reply #2 on: April 22, 2014, 09:26:05 AM »
Hello

Thanks for reply.
I use  Eddy-DK v2.1 development board.
I just want to use debug serial(UART) console.
I found that in kernel the RX interrupt from debug serial port was disabled. After enabled it everything works.

Regards
kaml