Author Topic: TE600 JTAG programming  (Read 3541 times)

tare_izo

  • Active Member
  • *
  • Posts: 2
TE600 JTAG programming
« on: April 07, 2014, 11:16:32 AM »
Hello,

I have TE600-02 and TE603 carrier board and I am experiencing difficulties to download .bit file into the FPGA. I am using Digilent HS1 JTAG-usb cable.
When I open ISE iMPACT and try to download file I get next message :

INFO:iMPACT - Current time: 7.4.2014 11:08:11
PROGRESS_START - Starting Operation.
INFO:iMPACT:583 - '1': The idcode read from the device does not match the idcode in the bsdl File.
INFO:iMPACT:1578 - '1':  Device IDCODE :        00001111111111111111111111111111
INFO:iMPACT:1579 - '1': Expected IDCODE:    00000100000000010001000010010011
PROGRESS_END - End Operation.

Elapsed time =      0 sec.

I would appreciate any help or tips.
Thank you.

Tarik.

Oleksandr Kiyenko

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 404
Re: TE600 JTAG programming
« Reply #1 on: April 07, 2014, 01:42:42 PM »
Hello,

Usually such behaviour caused by bad cable connection.
Do you able to see chip in iMPACT on start ?
Do you have correct power supply for your board ?

Best regards
Oleksandr Kiyenko

tare_izo

  • Active Member
  • *
  • Posts: 2
Re: TE600 JTAG programming
« Reply #2 on: April 07, 2014, 03:04:11 PM »
Hi Oleksandr,

Yes I can see my chip in iMPACT after Boundary Scan (see attachment). Only after I click to program chip I get message of IDCODE mismatch.
For power supply I am using  9V DC adapter connected to power connector J13.

I bought JTAG cable from Digilent
 http://digilentinc.com/Products/Detail.cfm?NavPath=2,395,922&Prod=JTAG-HS1

Thank you.
Regards.

Tarik.