Trenz Electronic Products > Trenz Electronic FPGA Modules

Broken JTAG on TE0701-03 / TE0720

(1/5) > >>

Leon:
Hi,

I was able to use iMpact and and a USB cable to access the JTAG on the Zynq. I could see both ARM DAP and the FPGA PL. However, after fiddling with the DIP switch S3 on the base board, I cannot get this again. Instead I get a chip 'unknown'':
INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.4
INFO:iMPACT - Digilent Plugin: found 1 device(s).
INFO:iMPACT - Digilent Plugin: opening device: "TE0701-03", SN:251633000091
INFO:iMPACT - Digilent Plugin: User Name: TE0701-03
INFO:iMPACT - Digilent Plugin: Product Name: JTAG-ONB4
INFO:iMPACT - Digilent Plugin: Serial Number: 251633000091
INFO:iMPACT - Digilent Plugin: Product ID: 50800157
INFO:iMPACT - Digilent Plugin: Firmware Version: 0109
INFO:iMPACT - Digilent Plugin: JTAG Port Number: 0
INFO:iMPACT - Digilent Plugin: JTAG Clock Frequency: 10000000 Hz
INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.4
INFO:iMPACT - Digilent Plugin: Opening device : "SN:251633000091".
INFO:iMPACT - Digilent Plugin: User Name: TE0701-03
INFO:iMPACT - Digilent Plugin: Product Name: JTAG-ONB4
INFO:iMPACT - Digilent Plugin: Serial Number: 251633000091
INFO:iMPACT - Digilent Plugin: Product ID: 50800157
INFO:iMPACT - Digilent Plugin: Firmware Version: 0109
INFO:iMPACT - Digilent Plugin: JTAG Port Number: 0
INFO:iMPACT - Digilent Plugin: JTAG Clock Frequency: 10000000 Hz
Attempting to identify devices in the boundary-scan chain configuration...
INFO:iMPACT - Current time: 10/03/2014 13:19:36
PROGRESS_START - Starting Operation.
Identifying chain contents...INFO:iMPACT:1588 - '0':The part does not appear to be Xilinx Part.
'0': : Manufacturer's ID =Unknown , Version : 0
INFO:iMPACT:501 - '1': Added Device UNKNOWN successfully.

Am I now getting the baseboard CPLD? How do I get it back to seeing the Zynq?

Thanks
Leon

Oleksandr Kiyenko:
Hello Leon,

Please put DIP switch  S3, switch "C" back, it will enable JTAG.

Best regards
Alex

Leon:
Hi,

I should have said that I had already put the DIP switch SW3 back to its original position:
1 ON CM1
2 ON CM2
3 OFF JTAGEN
4 OFF user

It still does not work.
Regards
Leon

Antti Lukats:
please drop me a short email or support@
I can send internal test tool that will show the CPLD revision, etc ...

SW.3 does either FORCE CPLD to be in chain, or restores the FTDI-JTAG pins to be user IO in the CPLD, so CPLD can re-assign the JTAG from FTDI to module JTAG.
If CPLD is erased, then SW.3 has no effect and JTAG scan would always show CPLD in chain.

br
Antti

indar:
Hi,

I also have the same problem. Even I don't start doing anything till now (the boards are new and I didn't play with any switch nor jumper), in fact, I just follow the step-by-step tutorial on using vivado here:
https://wiki.trenz-electronic.de/pages/viewpage.action?pageId=10625459

And when I run impact, the tools says:
Identifying chain contents...INFO:iMPACT:1588 - '0':The part does not appear to be Xilinx Part.
'0': : Manufacturer's ID =Unknown , Version : 0
INFO:iMPACT:501 - '1': Added Device UNKNOWN successfully.

Any clues?

Thanks!
Indar

Navigation

[0] Message Index

[#] Next page

Go to full version