Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

DM9000B LAN Controller

Started by ckranich, December 16, 2013, 10:59:39 PM

Previous topic - Next topic


Hi All,

<At least I have to post something new to proof that this product is not dead; used a few eddies so far; more to come, finger crossed...>

I used the internal Eddy CPU 2.5 (WAN) Ethernet port without problems.

Now I tried to copy the DM9000B (LAN) circuit of the EVA Board - and failed.

dmesg etc. show that the controller is found and initialized. ifconfig eth1 also looks normal (with the exception that no
packets are sent or received).

In fact the cable connection is not detected (as seen on the EVA-Kit). So no Link/Speed LEDs come up and the AVDD18 pins show only a
signal of about 0.9V instead of 1.8V. Somewhere in the WEB I read about startup issues with the DM9000B controller and that the
MII interface is activated to an active level of 1.8V for a moment and then is switched to disabled state below 1V. This is exactly what I see.

I have now two different PCB layouts and I am quite sure that there is nothing wrong with the wiring.

I noticed that the configuration Resistor forces the controller to 8-Bit mode while the pin names point towards 16-Bit interface.
I tried with and w/o this resistor. As far as I understand this makes no difference as the driver detects the mode used.

I also tried to enlarge the filter cap for the AVDD18 from 22u to 100u (without any difference)

Any Idea what might be wrong?

Best regards,

     Christian Kranich


Please use following 2 line commands (without the '#' sharp character) to enable the LAN port:

# lanup eth1
# def save

I think the LAN port is not enabled by default when Eddy is

  • shipped;
  • initialized to its factory default values.

I have added here some Davicom documents for your references: