Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

TE0710 red SysLed flashing on custom carrier board.

Started by sjoshi, May 16, 2024, 12:12:51 PM

Previous topic - Next topic


We are working with a custom carrier board which should host a TE0710 module. On powering up the board and module, we have noticed that the red SysLED keeps flashing continuously.

It appears that there is a design flaw where we have overlooked the SC_nRST, EN1, BOOTMODE and NOSEQ inputs to the module. The EN1 and SC_nRST pins can still be used, however BOOTMODE and NOSEQ are left unconnected in the design. On pulling SC_nRST high, the red SysLed stops flashing.

Vivado cannot detect the target even if EN1 is high or low. I am afraid that BOOTMODE or NOSEQ play a crucial role in initializing the Artix 7. We are currently using a TE0790 as the programmer. The JTAG pins have been connected in a scheme similar to that used on the TE0706.

Is there a way we can still rescue the board? Can we use a custom firmware for the onboard Lattice which can overlook the NOSEQ and BOOTMODE pin states and let us access the FPGA over JTAG? The JTAGSEL signal is pulled low.


I can program the module from a TE0705 board. When I plug the module in our carrier board and pull SC_nRST and EN1 high, the module configures itself from memory and my blinker code works. We seem to be missing JTAG access from our carrier board although I have read on the forum that the JTAG signals are simply patched through. JTAGSEL = 0 also seems to be the suggested setting.


JTAGSEL bin you can switch between Lattice CPLD and AMD FPGA. JTAG SEL=0 is FPGA(JTAG will forwarded through the CPLD to the FPGA). In case you use JTAGSEL=1, you should see unknown device normaly on vivado HW Manager.

Which programmer did you use on your carrier board?

Check also TDI/TDO, maybe they are swapped in your design?

BOOTMODE or NOSEQ are optional for TE0710 with native FPGA on both available firmwares and are no matter for JTAG:
or older version for modules which was delivered before feb 2024:




I have tried connecting to the board by swapping TDI and TDO but I still get an error message saying that "No devices detected on target".

We are connecting a TE0790 to the carrier board. Are there any other configuration pins I might be missing?


Me again. I have found the issue. Turns out that the design was done assuming that the XMOD will be connected upside down, meaning the odd and even pins were swapped. The second issue while using the TE0790 was the DIP switch 4. This is documented in the TE0706 documentation which was used as a reference design so it was easy to figure out.

Thanks for confirming that the Lattice FPGA has no role other than that what we had assumed.