Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

TEM0001-01A - UART transmission issues with the "test board" reference design

Started by pmjobin, May 23, 2023, 07:41:16 PM

Previous topic - Next topic



I bought a SMF2000 FPGA module in early 2019 and just got around to trying it out. As a first step (after installing Libero 21.2 and before overwriting the factory image), I opened a serial terminal on the COM port (115200 bauds 8N1) that appeared after I connected the board to my PC in order to validate that the serial connection was working as intended, which it did. The message that was displayed in the terminal was a large "MICROSEMI" title followed by "Hello PolarFire! This is SmartFusion2.". I'm pointing this out in case it helps identifying the factory image that was present on my board.

Next, I programmed the "TEM0001_test-board_Libero-2021.2" reference design provided on your website using the FlashPro Express method outlined in the wiki. In other words, I did not rebuild the design, I merely took the image straight out of the archive and programmed it as is on the board. Since then, all the text that appears in the serial terminal is garbled. I tried playing with the COM port settings to no avail. I believe the image was programmed correctly because the led patterns operate as expected. I also managed to connect to the JTAG port and step through the code of the "HelloWorld" application in SoftConsole.

Before diving further, I would prefer to get the serial communication up and running with the reference design. Any suggestion as to what steps I should take next?


Kilian Jahn

Hello pmjobin ,
i am the one who build the design for this board. I downloaded the online zip file like you did and I check on my board the design via FlashProExpress programming, via Libero programming with and without recompiling and soft core updates. I could not reproduce your error.

Your Uart settings are right , but your error description brings to my mind that the Uart Terminal and the board are out of sync . Can you try a different Uart Terminal ? I tried SmartTTY and Softconsole , both worked fine on my board .

There are older Demo projects available . They are based on a different Hardware and Software Design .
Via " Download  ->  lab_guides  ->  archive " you will find everything that you need .
The guide "SMF2000_Cortex_M3_PWM_lab_guide_Lib2021d3_SC2021d3_v1.5.pdf "
explains it in great detail . Most interesting is the demo "RTC_time application" .

Regards Kilian


Hello Kilian,

Thank you for your help. I followed all the instructions from the lab guide as you suggested and the serial terminal is now displaying correctly formatted text again. This validates that my hardware & software setup is functioning correctly.

Concerning the reference design, on thing I noticed will browsing the source code of the helloWorld SoftConsole project is that the baudrate is set to a non-standard value of 161280 (see attachment). I tried changing it back to 115200 and rebuilding the project but it did not fix the serial transmission corruption issue I was experiencing.

Thanks again,

Kilian Jahn

Hello P-M,
in order to achiev the maximum SoC / DDR speed for testing, i had to use a non standard Uart speed.

Pardon for your inconvenience.

As i was altering the Software to step true a range of Uart speeds, I encounter
the same problem .
Changing the clock speed of the hardware design + Software speeds to
achieve standard conformity produced the same problem.
So my conclusion is as follows :

Thank very mutch you for making me aware of this problem.

I will correct this error (Complett new project) . I am currently not sure when .

Kind regards Kilian