Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

Setting TE0715 in JTAG mode to program QSPI FLASH

Started by aliverud, April 26, 2023, 01:46:12 PM

Previous topic - Next topic


I am trying to set a TE0715-04 on a TE0701-06 carrier board to boot a sample program from the QSPI FLASH.
However I am not able to program the QSPI FLASH as I cannot set boot mode to JTAG as required by "Xilinx Program Flash".
I have tried to change the boot mode in a petalinux console (i2cset -y 0 0x20 0x1 0x91 as described here: )
This fails as the TE0715 CPLD firmware needs to be updated (?). I have tried to update the firmware as described here:
However CPDL upgrade fails due to an too old carrier board (TE0701-06) if I understand this correctly. Also, the updated CPDL firmware is only available for the rev. 5 of the TE0715 board from what I understand, I have TE0715 rev. 04 board.

Is it possible to configure this revision of boards to boot and run from QSPI FLASH? If so, please advice on how to proceed?


Hi, you can't reprogram CPLD of the module with TE0701, sorry.

Is there a reasion why you didn't use SD Boot? Simple put boot files on SD Card(FAT32) and boot from SD. On TE0701, SD boot will be selected when you insered a SD card.

Other option, use Vivado Labtools 2017.2 (programmer only, you can download them separately from ADM(Xilinx)).
Here is some backround around this topic:


Hi John,
I would like to separate boot and storage for my application. I plan to use the SDcard for storage and QSPI FLASH for application boot.
I was able to program and boot from the QSPI FLASH using the Vivado Labtools 2017.2 as advised.
Thanks a lot for the help.
Best regards,


I'd also like to jump into this thread. I recently wrapped up a project using a TE0715-05 and a custom carrier board where everything was handled in QSPI (no SD card was present). I am now working on getting the same functionality for a few TE0715-04 boards I have, but am struggling to get them to do anything. I followed the same steps for the 04 as I did with the 05, and it says they are being programmed successfully, but the boards do not boot, and there isn't even a boot menu I can get into on startup.

Is there a pin I should be setting or any ideas?




Hi John!

I went ahead and sent an email. Perhaps we can continue this off the forum.

Thanks for the quick reply,