Author Topic: TE720 QSPI boot corrupting  (Read 400 times)

akarcher

  • Active Member
  • *
  • Posts: 7
TE720 QSPI boot corrupting
« on: October 19, 2022, 11:20:05 PM »
I have moved a working design from SD-card boot and rootfs to boot from QSPI with image.ub on the boot partition of the eMMC, Rootfs on an ext4 partition of eMMC. This works very well. However at rare and random intervals (~ once a month) the QSPI gets corrupted and I have to re-flash the boot.bin to QSPI to be able to boot. I have no idea how this could happen. Any input would be appreciated. Since this happens so rarely I don't know how to debug this effectively. Since the rootfs is not effected all log files are still present.

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2001
Re: TE720 QSPI boot corrupting
« Reply #1 on: October 20, 2022, 07:00:27 AM »
Hi,
I have never heard of such a issue. For eMMC yes(if they don't shutdown properly, it can happen, that emmc is corrupted), but never from QSPI. Do you read/write something to the QSPI Flash with your design?. You could run our prebuilt Linux from the reference design and see if you can reproduce this issue? I know it's hard to find out what's happens, when I hear it appears very rarely.
br
John

JS

  • Active Member
  • *
  • Posts: 32
  • FPGA-Design & Signal Processing
Re: TE720 QSPI boot corrupting
« Reply #2 on: December 06, 2022, 06:01:25 PM »
Do you have access to a logic analyser capable of reporting qspi signals and their meaning?