Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

problem with booting from the SD card

Started by boki, September 26, 2022, 05:27:22 PM

Previous topic - Next topic


Hi folks,

I have a problem with booting from the SD card (TEBF0808-04A + TE0807-03-7DE21-AK).
When I couldn't get it to work with my own design (baremetal app which runs fine via JTAG) I downloaded the starter kit and extracted the prebuilt files for 2020.2.
I took BOOT.bin from boot_hello_te0807 folder and copied it to the root of several FAT32 formatted SD cards (tried with 3 different types).
DIP switch S5-1 and -2 are set to "ON" position. After powering the board and pressing S1 button I get the following message on the UART terminal:

Xilinx Zynq MP First Stage Boot Loader (TE modified)


So it starts but it hangs without putting out the Hello world (similar to what happens in my own design).
I also notice that red LED on SoM module doesn't switch on, indicating FPGA is not programmed.
Can you please tell me what am I doing wrong?
Thanks in advance.



which external power supply did you use? Some current limit?
Did you use correct Boot.bin for your assembly variant (TE0807-03-7DE21-A)? Download includes files for different assembly variants, so it's important to use the correct one. There is a small sticker with QC code on the heat spreader of the module. I can check one time your assembly version, to see  if TE0807-03-7DE21-A is correct.



I'm using a 12V/5A brick, so supply shouldn't be a problem.
I run the _create_win_setup.cmd, chose the assembly and got _binaries_TE0807-03-7DE21-AK folder from where I took BOOT.bin.
I attached a picture of the sticker, is that the one you want?


yes your 654242 is TE0807-03-7DE21-A from Feb. 2021(shipping date). Do you have some history about the module?

TEBF0808 has some LEDs, can you tell me the state of the LEDs, when programming failed, see:

Can you remove the module one time and plug on again, maybe there are some bad contacts.


TEBF0808 board together with the module was previously used by a colleague, always in JTAG mode.
Btw I have another TEBF0808 with another module (720475 on the sticker) - same behavior.
Removing the module and putting it back doesn't help.

After powering the board and pressing S1 button the LEDs are as following:
D7 red 1 times fast blink with a break = SD Boot
D6 green OFF = Main Power State Machine Ready
XMOD1 D4 red OFF = all fine
XMOD2 D4 red fast blinking = PS Init low
SFP D1 red fast blinking = PS Init low
SFP D8 green fast blinking = PS Init low
D17 green ON = no USB connected
SFP D9 red fast blinking = PS Init low
SFP D10 green fast blinking = PS Init low
ETH leds also fast blinking = PS Init low
D4 green 1 times fast blink with a break = all fine
D5 red 1 times fast blink with a break = all fine

PS Init low is bad, right?


PS Init low  comes from ZynqMP, because Zynq has some problems on booting.
Other serial is TE0807-03-S001, the same files like TE0807-03-7DE21-A can be used there.

Ca you try out 2021.2 binaries?

Which SD Card slot did you use? Micro or the normal SD card slot? Can you use the other one one time?

Can you also program one Time QSPI Flash with the Hello TE0807 Boot.bin and try to boot from QSPI?

On the other Carrier/Module combination, did you use the same power supply unit? If yes, can you try one time another one or best case ATX power supply?
12V5A is enough but  I would like to exclude this if possible, so it would be worth a try.



Hi John,
Tried 2021.2, makes no difference.
Tried both SD and micro slots, same behavior.
Second board/module combination has another brick supply.

Tried to boot hello_te0807 from QSPI and it works. After that tried my own design booting from QSPI and it also works.

So for some unknown reason SD refuses to boot while there is no problem with QSPI with the same .bin files.
I decided to use the QSPI from now on, can live with that.

Thanks for your support,


hm strange. Change SD card can help, I've seen this sometimes. What you can also try is to boot uboot from QSPI and check if uboot can get access to SD. Bootrom, FSBL, Uboot, linux...every step will reinitialise SD interface again. Boot Rom was working(run with low speed)...FSBL seems to get problems...