Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

Petalinux Build [Errno 32] Broken Pipe

Started by DR, December 01, 2022, 05:17:36 PM

Previous topic - Next topic


Hello Petalinux Fans,

For several reasons beyond our control :( We are required to use Ubuntu 22.04 or Fedora 36 on our Systems.
For the past few months, I have been struggling to get the test_board project for TE0820 to build under either of these systems.

The first issue I encounter is a change in "c-stack.c" which can be solved by a patch found here:

I have not been able to come up with a work around for the second issue ...
Just before the build completes, Petalinux stops with this error:
ERROR: Failed to spawn fakeroot worker to run /home/drector/test_board/os/petalinux/components/yocto/layer/core/meta/recipes-core/initscripts/ [Errno 32] Broken Pipe

This is the stock
With Vivado 2021.2, Petalinux 2021.2 and either Ubuntu 22.04 or Fedora 36
No changes except the patch for c-stack.c

Searching the web reveals a few others with the same issue, but no solution.

The surprising thing to me is that more people haven't hit this issue yet over the past few months.

Anyone else see this and have a work-around?

Rebuilding the System with Fedora 34 or Ubuntu 20 - it all works fine out of the box.

Thanks for your help.

M Kirberg


we do not try to run Petalinux on non-supported OSes.
I think this error dives deep into Yocto and behaviour of specific OS Version.

We use Petalinux (aka Yocto Gatesgarth) as a Docker Image with Ubuntu20 to avoid these issues, maybe this can be setup on your System?

If not, I tried to find something in Yocto, maybe something like this Patch would help



Thanks much for the hint and looking into this with me ...

I tried the patch to bitbake-worker - which looked like it might solve my problem, but unfortunately, no - still getting the same "Failed to spawn fakeroot worker" [Errno 32] Broken pipe.

Anyone else see this or have any ideas.

I would like to stick to Ubuntu 20 as suggested, but our systems forbid network bridging, which is required for such a Docker.

Plus, eventually, it seems like this is going to need a solution as more people use Ubuntu 22?


QuotePlus, eventually, it seems like this is going to need a solution as more people use Ubuntu 22?
you are right, but petalinux is provided by AMD(Xilinx), and they only support selected Linux distribution....
For 2022.2 it's at the moment only:

  • Red Hat Enterprise Workstation/Server 7.4, 7.5, 7.6, 7.7, 7.9, 8.2 (64-bit), 8.3, 8.4, 8.5, 8.6
  • CentOS Workstation/Server 7.4, 7.5, 7.6, 7.7, 7.9
  • Ubuntu Linux Workstation/Server 18.04.1, 18.04.2, 18.04.3, 18.04.4, 18.04.5, 18.04.06, 20.04, 20.04.1, 20.04.2, 20.04.3 ,20.04.4 (64-bit)
  • SUSE Linux 15.2
only AMD(Xilinx) can changes this...

M Kirberg

For clarity: the dependency actually set by the Yocto Project not by Xilinx itself, for petalinux 2021.2 == Yocto Gatesgarth this is:

Petalinux is an additional layer which has its own dependencies, but your error seems clearly caused by the former one.

Ok a pity that this patch is not working.
I mean the error message suggest that it bitbake-worker is at fault

You can additionally try to find patches in the history of files, e.g. here
and apply them selectively.
Or even try to use the latest version from master and see if that is any good.



Yes Markus,
Thanks again for the help.
and - Yes I tried various permutations of the patches on bitbake - most of them wound up breaking with many dependencies that relied on other patches that were incompatible with the current version that I was using.
When I tried to use the latest version of everything from master together, then many other dependencies were broken deeper in. It was a painful experience. Especially since so many files had to be manually fixed to accommodate the current libraries. Then checksums were broken ... what a mess.


I want to ask about how to upgrade to the latest updates. Does it cause any effects?