Author Topic: 1Gbps Ethernet link state toggling (up/down) on TE0802-2 with connected EthCable  (Read 115 times)

Tobi

  • Active Member
  • *
  • Posts: 1
Hello,
I'm having multiple Trenz TE0802-2 evaluation boards at my desk (some with serial no. 6581XX which seem to work fine, some with serial no. 6998XX which having my issue).

I created a bootable SD card image (configured & built PetaLinux 2021.2). The system is booting successfully.
Then I connected the Trenz board to my PC Network Interface Card (NIC, which is a Intel(R) Ethernet Connection (7) I219-LM).
The Ethernet link comes up, ETH-connection is established, after some time the link is falling down, without any interaction from my side (e.g. disconnecting the Eth-cable), it comes up again, falling down, and so on.

- I tested with several different network cables, also brand new ones
- I checked already my "faulty" boards with SD card images from colleagues = my boards still having link drops
- My colleagues tested my image on their board = they having no link drops on their boards
- So it should not be related to a special kernel configuration or device tree modification
- How it looks like on the console you will find at the end of the following log:

Code: [Select]
...
Configuring network interfaces... [    9.270684] macb ff0e0000.ethernet eth0: PHY [ff0e0000.ethernet-ffffffff:01] driver [Marvell 88E1510] (irq=POLL)
[    9.280933] macb ff0e0000.ethernet eth0: configuring for phy/rgmii-id link mode
[    9.289560] pps pps0: new PPS source ptp0
[    9.293719] macb ff0e0000.ethernet: gem-ptp-timer ptp clock registered.
udhcpc: started, v1.32.0
udhcpc: sending discover
udhcpc: sending discover
[   13.393562] macb ff0e0000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[   13.401304] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
udhcpc: sending discover
udhcpc: no lease, forking to background
done.
Starting haveged: haveged: command socket is listening at fd 3
haveged: haveged starting up


Starting Dropbear SSH server: dropbear.
starting Busybox HTTP Daemon: httpd... done.
Starting internet superserver: inetd.
Starting syslogd/klogd: done
Starting tcf-agent: [   19.317283] random: crng init done
OK

PetaLinux 2021.2 te0802_os ttyPS0


root@te0802_os:~# ethtool eth0
Settings for eth0:
        Supported ports: [ TP    MII     FIBRE ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Transmit-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Transmit-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Auto-negotiation: on
        Port: MII
        PHYAD: 1
        Transceiver: external
        Link detected: yes
root@te0802_os:~# ifconfig
eth0      Link encap:Ethernet  HWaddr E8:EB:1B:12:91:27
          inet6 addr: fe80::eaeb:1bff:fe12:9127/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1890 (1.8 KiB)  TX bytes:3184 (3.1 KiB)
          Interrupt:36

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@te0802_os:~# [  118.863098] macb ff0e0000.ethernet eth0: Link is Down
[  120.912611] macb ff0e0000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[  165.967130] macb ff0e0000.ethernet eth0: Link is Down
[  169.040606] macb ff0e0000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[ 1222.735104] macb ff0e0000.ethernet eth0: Link is Down
[ 1225.808612] macb ff0e0000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
...

- maybe it is linked to the assembled Marvell 88E1512-NNP2 chip, which divers on my boards:

1x working board has a Marvell chip designated:
88E1512-NNP2
N4CH790.09JW
2112 A0P --> Year 21 Week 12
TW


4x faulty boards have a Marvell chip equipped with designation:
88E1512-NNP2
N3NF600.10JW
2025 A0P --> Year 20 Week 25
TW


1) Could that link drop issue be a known issue related to this specific production date of the chip which is assembled on my faulty boards with serial no. 6998XX?

2) Are there any recommendations how to find out the rootcause of my issue?


Best regards
« Last Edit: October 28, 2022, 04:32:37 PM by Tobi »

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1971
Hi,
can you send me the exact serial number of your modules with the ETH Problem?
Maybe they are effected on this AVN;https://wiki.trenz-electronic.de/display/PD/AVN-20211202+Problematic+MEMS+Oscillator

Can you send the serial numbers to "support@trenz-electronic.de"
br
John