Author Topic: TE0820 + TE0701 + QSPI boot => Micro SD card not detected after boot  (Read 431 times)

DR

  • Active Member
  • *
  • Posts: 8
Hello Everyone,

I have gone through the "test_board" reference design for the TE0820 + TE0701 Carrier.
Using Vivado 2021.2 and Petalinux 2021.2
SD Card booting works fine
I managed to get the BOOT.BIN image created and installed on the QSPI - also booting fine - no problems

However, when I insert an SD Card into the SD slot after boot time, it is not recognized and does not mount.

If I insert the SD Card during boot time (i.e. after the QSPI image is loaded and starts running, then the SD Card is recognized and mounted automatically.

I suspect this is because the Card Detect signal is not being used for Card insertion events.

Has anyone been able to work around this issue and gotten the SD Card to be recognized after inserting after boot has completed?

Possible solutions I have been investigating with no success are:
1) Somehow get the sdhci driver to rescan the SDIO bus? Is there a module command for this?
2) Set the sdhci driver to poll the SDIO bus to see if there are any changes in state. Again, I have not figured out a way to set this up.

Thank you for your help.
Dave

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1969
Hi,
maybe it's easier to change TE0701 CPLD --> remove CD Pin from Boot mode selection and set constant to QSPI.
Source code and update instructions:
https://wiki.trenz-electronic.de/display/PD/TE0701+CPLD+Firmware
And keep SD inside after power on

Linux SD reinitialization should also be possible, but I can't tell you off the top of my head how you do this.

br
John