Author Topic: Lemon IDE and debug port on eddy S4M-DK v2.1  (Read 14133 times)

paulms

  • Active Member
  • *
  • Posts: 8
Lemon IDE and debug port on eddy S4M-DK v2.1
« on: December 01, 2011, 12:12:50 PM »
I'm operating under windows the Lemon IDE. I've followed the instructions closely. using the example hello code.
The one problem that i'm facing is not able to get the target browser to work under the serial interface, if i telnet in and use tae it works.
The serial port is set up correctly as the serial port shows information on boot up and when i logon via telnet.
I've tried pressing a key on boot up and get no response to stop the boot up.
I've confirmed that the serial port on the computer is working correctly (TX and RX)
Any help greatly welcome

Antti Lukats

  • Hero Member
  • *****
  • Posts: 542
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #1 on: December 01, 2011, 12:24:36 PM »
Can you tell us what exactly is not working?

Can you download the hello example to eddy?


paulms

  • Active Member
  • *
  • Posts: 8
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #2 on: December 01, 2011, 01:01:07 PM »
I've been following the lemonIDE user guide v1.0d and on section 5.5.2 the hello program should print out on the terminal (RS232 debug port) sadly it does not do this.
I can download the program to the eddy but only through a telnet connection, so using the LemonIDE serial method no I can't download it.

mkremer

  • Moderator
  • Active Member
  • *****
  • Posts: 14
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #3 on: December 12, 2011, 02:12:08 PM »
Hello Paulms, please excuse the late reply. If I have understood your questions correctly, you have no output to the terminal via the debug port.
Which windows operating system are you using?
Have you no output from the terminal which is integrated into LemonIDE?
In this case, when you want to use the serial terminal in LemonIDE, first you have to copy 2 dll files "rxtxParallel.dll" and "rxtxSerial.dll" into the windows system folder. Second you must copy the file "RXTXcomm.jar" into the java folder. 
Does it work with the Hyperterminal?
Do you want to load programs via serial port into Eddy?
« Last Edit: December 12, 2011, 05:32:04 PM by mkremer »

paulms

  • Active Member
  • *
  • Posts: 8
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #4 on: December 21, 2011, 09:11:13 AM »
that is correct I get nothing out on the debug port after boot up. I'm using Windows 7 professional, service pack 1. The lemonIDE terminal seems to be working correctly i've connected the rs232 port to another computer at can TX and RX over the rs232 port, so i guess this sort of proves the comms side of the computer is working.
basicly I want to be able output data to the debug port so i can debug my code.

mkremer

  • Moderator
  • Active Member
  • *****
  • Posts: 14
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #5 on: December 21, 2011, 11:01:38 AM »
1.) Appears the "standard terminal output at boot time" on Hyperterminal/LemonIDE terminal?
2.) Have you tested it with the Hyperterminal?
3.) If it works over Hyperterminal and not over LemonIDE terminal => Have you copied the .dll files into the system folder of your OS?
« Last Edit: December 21, 2011, 11:22:32 AM by mkremer »

paulms

  • Active Member
  • *
  • Posts: 8
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #6 on: December 21, 2011, 11:16:32 AM »
yes i do see the standard terminal output at boot time on both.
the dll files have been copied to the sys folder of the os

mkremer

  • Moderator
  • Active Member
  • *****
  • Posts: 14
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #7 on: December 21, 2011, 11:22:24 AM »
Have you enabled the LemonIDE Target Agent?

paulms

  • Active Member
  • *
  • Posts: 8
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #8 on: December 21, 2011, 11:50:38 AM »
Well i believe that I have. I've loged into the eddy board using internet explorer gone to network setup changed the Target Agent to enabled, then clicked submit.

mkremer

  • Moderator
  • Active Member
  • *****
  • Posts: 14
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #9 on: December 21, 2011, 04:04:47 PM »
I will try it on Win7 and then I`ll get back to you.

mkremer

  • Moderator
  • Active Member
  • *****
  • Posts: 14
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #10 on: December 27, 2011, 03:25:59 PM »
Have you the possibility to test it with windows XP?
According SystemBase, LemonIDE currently supports only up to winXP.
« Last Edit: December 28, 2011, 06:03:18 PM by mkremer »

mkremer

  • Moderator
  • Active Member
  • *****
  • Posts: 14
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #11 on: December 28, 2011, 06:03:37 PM »
In the first quarter 2012 SystemBase will publish a new version of LemonIDE which is compatible to Windows 7.

mkremer

  • Moderator
  • Active Member
  • *****
  • Posts: 14
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #12 on: April 03, 2012, 08:42:55 AM »
Hi Paulms. A new version of LemonIDE for Windows XP / Vista / 7 is now available on www.embeddedmodule.com.

paulms

  • Active Member
  • *
  • Posts: 8
Re: Lemon IDE and debug port on eddy S4M-DK v2.1
« Reply #13 on: April 03, 2012, 09:19:25 AM »
Thanks i'll try it out and let you know how it goes