Author Topic: JTAG boot on TE0803  (Read 595 times)

lea

  • Active Member
  • *
  • Posts: 2
JTAG boot on TE0803
« on: December 08, 2021, 10:14:54 PM »
Hello,

I am trying to bring up a custom carrier board with TE0803.
The SD card boot is fine, but if I try to boot using JTAG (dedicated PS interface, boot mode '0000') then nothing appears on the console.
The petalinux-boot (2020.2) does not give any error and give back the prompt finally.

Shall I build a different image for JTAG boot?

Thanks is advance for your reply.

Lea









JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1921
Re: JTAG boot on TE0803
« Reply #1 on: December 10, 2021, 10:06:58 AM »
Hi,
JTAG boot mode means only that ZynqMP will be wait for access via JTAG.
See: https://www.xilinx.com/support/documentation/user_guides/ug1085-zynq-ultrascale-trm.pdf
br
John

lea

  • Active Member
  • *
  • Posts: 2
Re: JTAG boot on TE0803
« Reply #2 on: December 10, 2021, 10:13:38 PM »
Hello John,

Thank you for your answer.

Maybe, I didn't share every details about this case. Now, I try...

So, when I switched the card to JTAG boot mode, I connected a Digilent HS3 to the JTAG interface of the TE0803. I believe the cable is OK.
Then, I followed "Boot a PetaLinux Image on Hardware with JTAG" in UG1144 (2020.2):

1. Prerequisties:
...
petalinux-build
petalinux-package --boot --format BIN --fsbl images/linux/zynqmp_fsbl.elf --fpga images/linux/system.bit --u-boot  (This resulted BOOT.BIN and image.ub for the SD card boot. SD boot is fine. Console is accessible on /dev/ttyUSB0)
petalinux-package --prebuilt --fpga images/linux/system.bit

2. JTAG boot:
petalinux-boot --jtag --prebuilt 3 --hw_server-url TCP:ubuntu:3121

I attached the result. It looks similar to "Loading PMU Firmware in JTAG Boot Mode" in UG1137.
The whole process seems fine, no error msgs and the power consumption gets the same value as if I booted from SD card.
One thing is missing... the console. That doesn' operate.

Can you see anything definite wrong step which leads to this phenomenon?

Thank you.

Lea








« Last Edit: December 10, 2021, 10:18:45 PM by lea »

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1921
Re: JTAG boot on TE0803
« Reply #3 on: December 14, 2021, 07:52:57 AM »
Hi,
I didn't use petalinux to program the modules, so I can't help much there. And in my opinion JTAG is not the best way to program ZynqMP, especially in case the Zynq has some configuration, which can prevent proper JTAG usages.

In your case I would do following:

Check if your PS configuration is correct for your assembly variant and your carrier?
In case you has an SD card on your carrier boot your design from SD to check if this works
In case you use GTR interfaces, check that you has valid reference clk soures. Note SI5338 is not programmed this will be done via FSBL only with our changes(we provide source code for Vitis in case you use tebf0808, if not you must modify I2C connection like it is set on your carrier)

br
John