Author Topic: Micro USB not working in TE0705 carrier and TE0715_04  (Read 940 times)


  • Active Member
  • *
  • Posts: 1
Micro USB not working in TE0705 carrier and TE0715_04
« on: October 14, 2021, 07:50:10 PM »
I am new to this board and wanted know few things.
carrier TE0705-04 , module -TE0715_04_30

1. I want to access the Micro USB on the board. I have installed all necessary drivers in the kernel. I have booted the petalinux 2020.1 using the reference design (SD card). The petalinux boots up fine and it shows all the drivers for USB are ready. But when i insert a pendrive using converter, it does not detect the USB.
I have used the FSBL provided in the reference design. still it does not work. I also red the article saying it needs to be Reset and i tried to add that piece of code in Fsbl_hooks.c (do i have to build the project to get FSBL.elf)?, this time linux does not boot at all.
Please can any of you suggest me what am i doing wrong? I have notices the pendrive have an LED indicator and that not not light up once plugged in as well. is this a voltage issue or FSBL configuration?

2. The pinout of the carrier and module board confused me a little.
I tried to add an LED to refernce design, but i could not find which pin should i assign in vivado. since the control goes via CPLD . can anyone suggest how to access it, from FPGA to B2B connector and from there to CPLD and LED?

Thank you in advance


  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1987
Re: Micro USB not working in TE0705 carrier and TE0715_04
« Reply #1 on: October 15, 2021, 02:03:09 PM »
do not mix binaries from different version.

Please try out our prebuilt binaries from the reference design, also linux images is included.
Newest Reference design is 2020.2:

Put Boot.bin, image.ub, boot.scr from your assembly variant on SD and boot design. SoC is host and you can connect USB stick.

Everything what we have changed on petalinux manually is described here:

Regarding LED of the TE0715 which is connected on CPLD:
It's not controllable with the current firmware:

« Last Edit: October 15, 2021, 02:04:44 PM by JH »