Author Topic: Compile error of TEI0001-test_board-quartus_19.1.0-20200707153205.zip  (Read 257 times)

norineko

  • Active Member
  • *
  • Posts: 5
Hi,

I have downloaded "TEI0001-test_board-quartus_19.1.0-20200707153205.zip" and executed "create_project_win.cmd".
I selected TEI0001-02-08-C8 and pushed "Create project" button.
But I got some error messages as follows.

Info: Adding uart [altera_avalon_uart 19.1]
Info: Parameterizing module uart
Info: Building connections
Info: Parameterizing connections
Info: Validating
Info: Done reading input file
Error: NIOS_test_board.onchip_flash: Must assign a valid Device for Altera Onchip Flash megafunction.
Error: [TE_DES-30] Script (TE::QUART::generate_qsys) failed:
Error: [TE_TK-11] (TE) Script (TE::DES::run_project) failed: .


My Quatus environment is as follows.

Quaturs Prime Version 19.1.0 Build 670 09/22/2019 SJ Lite Edition
Nios 2 software build Tool for Eclipse Version: Mars.2 Release (4.5.2) Build id: 20160218-0600

What is necessary to create project?

Thank you.

t.dueck

  • Active Member
  • *
  • Posts: 11
Re: Compile error of TEI0001-test_board-quartus_19.1.0-20200707153205.zip
« Reply #1 on: August 13, 2020, 07:10:24 AM »
Hi,
did you install the device support file for the MAX 10 FPGA?

br
Thomas

norineko

  • Active Member
  • *
  • Posts: 5
Re: Compile error of TEI0001-test_board-quartus_19.1.0-20200707153205.zip
« Reply #2 on: August 14, 2020, 03:36:42 AM »
Thank you for your prompt reply :).

I found that device support file was not installed.

I will install it and try again.

Many thanks.

norineko

  • Active Member
  • *
  • Posts: 5
Re: Compile error of TEI0001-test_board-quartus_19.1.0-20200707153205.zip
« Reply #3 on: August 16, 2020, 03:21:32 AM »
Hi,

I have installed device support file and try again.

"Must assign a valid Device for Altera Onchip Flash megafunction." message is disappeared,
and I got another error messages :'( as follows.

Info: [TE_SDK-10] Create app -> done
------------------------------
Info: [TE_SDK-23] Modify sdk files. Please wait ...
Error: [TE_DES-64] Script (TE::SDK::modify_sdk_files) failed: couldn't open "C:/********/project/test_board/software/test_board/Makefile": no such file or directory
Error: [TE_DES-31] Script (TE::DES::run_sw_project) failed:
Error: [TE_TK-11] (TE) Script (TE::DES::run_project) failed: .
Info: [TE_DES-62] 'Create Project' GUI closed.

I find that there is no "Makefile" on my workspace "C:/********/project/test_board/software/test_board/"
and "TEI0001-test_board-quartus_19.1.0-20200707153205.zip" doesn't contain "Makefile".

Could you give me some advice about this problem?

Thanks.


t.dueck

  • Active Member
  • *
  • Posts: 11
Re: Compile error of TEI0001-test_board-quartus_19.1.0-20200707153205.zip
« Reply #4 on: August 17, 2020, 06:56:41 AM »
Hi,
are you using Win10? If yes, did you install Windows Subsystem for Linux (WSL), like described here (Chapter 2.3.1): https://www.intel.com/content/www/us/en/programmable/documentation/esc1425946071433.html#puq1561069548076 ? It's needed for Nios II EDS.

Can you send me the whole log file, please? You'll find it in the log folder.

br
Thomas

norineko

  • Active Member
  • *
  • Posts: 5
Re: Compile error of TEI0001-test_board-quartus_19.1.0-20200707153205.zip
« Reply #5 on: August 18, 2020, 03:15:09 AM »
Thanks for your reply :)

I have confirmed that WSL is installed(ubuntu18.04 LTS) and Nios II EDS can be launched from Quatus menu Tools->Nios 2 software build Tools for eclipse(Mars.2 Release (4.5.2)).

I will attach my log file.

Sorry to bother you.

t.dueck

  • Active Member
  • *
  • Posts: 11
Re: Compile error of TEI0001-test_board-quartus_19.1.0-20200707153205.zip
« Reply #6 on: August 18, 2020, 10:06:04 AM »
Hi,
you're using wsl 2. You have more problems using Nios II EDS with wsl 2 than with wsl 1, so it's better to change to wsl 1. The scripts of this project should work with wsl 1.
Follow the steps below, to change wsl 2 to wsl 1:
  • Open PowerShell as Administrator
  • run command: wsl --set-default-version 1
  • run command: wsl --set-version Ubuntu-18.04 1
  • check, if wsl 1 is assigned to ubuntu 18.04 with command: wsl -l -v

Then try again to create the project for your MAX1000.

br
Thomas

norineko

  • Active Member
  • *
  • Posts: 5
Re: Compile error of TEI0001-test_board-quartus_19.1.0-20200707153205.zip
« Reply #7 on: August 21, 2020, 04:29:49 AM »
Thanks for your reply.

I successfully created the project file!!

Thank you very much!!