Author Topic: TE0720-03-1CFA does not show when selecting the board  (Read 534 times)

amamory

  • Active Member
  • *
  • Posts: 10
TE0720-03-1CFA does not show when selecting the board
« on: May 31, 2020, 01:04:41 AM »


I am using Vivado 2019.2 and this https://shop.trenz-electronic.de/en/TE0720-03-1CFA-S-TE0720-03-1CFA-S-Starter-Kit?c=373.
TE0720-03-1CFA does not show when selecting the board

I downloaded the reference design from
https://shop.trenz-electronic.de/en/Download/?path=Trenz_Electronic/Modules_and_Module_Carriers/4x5/TE0720/Reference_Design/2019.2/test_board

then I copied the files from test_board\board_files\TE0720_1C to the board_files dir in Vivado (Xilinx/Vivado/2019.2/data/boards/board_files).

First weird thing is that when i try to created a new Vivado project, the board TE0720-03-1CFA does not appear. Only ZYNQ-7 TE0720-*-1CR appear.

It seems that Vivado only shows the latest version of the board_files, in this case V2.0. After I deleted est_board\board_files\TE0720_1C\2.0, then Vivado found the TE0720-03-1CFA board.

I only figure out which one was related to TE0720-03-1CFA after finding this post.

https://forum.trenz-electronic.de/index.php/topic,865.msg3812.html#msg3812

The last sentence, quite hidden, one can read:

test_board\board_files\TE0720_1C   (1.0 --> is for 1CF and 1CFA)

Quite a relevant information to be out of the docs !!!

If what I am seem is correct, please fix it at https://shop.trenz-electronic.de/en/Download/?path=Trenz_Electronic/Modules_and_Module_Carriers/4x5/TE0720/Reference_Design/2019.2/test_board

best regards,
Alexandre


JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1605
Re: TE0720-03-1CFA does not show when selecting the board
« Reply #1 on: June 02, 2020, 07:18:37 AM »
Hi,
use scripts to generate the project and instanciate board files localy:
https://wiki.trenz-electronic.de/display/PD/TE0720+Test+Board#TE0720TestBoard-DesignFlow

PS: In your case select Board REV all on Vivado to see different board files, see attachment.

br
John

amamory

  • Active Member
  • *
  • Posts: 10
Re: TE0720-03-1CFA does not show when selecting the board
« Reply #2 on: June 02, 2020, 04:09:21 PM »

So, if I am understanding what you are saying, it is not recommended to start a vivado project 'in the usual way'. is it correct ?
should i remove trenz boards from the list of boards when we are creating a new vivado project ? this would avoid this issue in the future ...

thanks,
Alexandre

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1605
Re: TE0720-03-1CFA does not show when selecting the board
« Reply #3 on: June 02, 2020, 04:20:47 PM »
Hi,
you can do like you prefer.

Instead to copy directly into vivado folder, you can also define a directory for vivado, see:
https://wiki.trenz-electronic.de/display/PD/Installation

But Reference designs are designed in this way that they can be run without any copy of board files. And reference design includes also SW parts, see test_baord documentation

But you should use only one method, otherwise you can be never be sure which board file vivado use (theoretically it's shown in the summary window of your vivado project, but different compiling steps seems to search again board files).

br
John

amamory

  • Active Member
  • *
  • Posts: 10
Re: TE0720-03-1CFA does not show when selecting the board
« Reply #4 on: June 03, 2020, 12:01:15 AM »
thanks John,

with your extra info, this issue can be closed.

Alexandre