Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

TE0703 + TE0820 .... cannot connect Target under Ubuntu Linux

Started by w1bworx, April 05, 2020, 04:13:21 PM

Previous topic - Next topic


Hopefully this is a silly problem with a simple answer !!
I have done several projects using MpSOC and usually develop code on Big old MacPro using Windows10 running Virtua; [VMware-Fusion]
Been no problem at all !!

Latest project requires a Linux operating system to run on the APU with some bare metal code on the RPU and some custom FPGA cores.
So I moved everything over to Ubuntu 18.04 [also a virtual on the same machine].
I have not used Linux in anger before so feeling my way a little ...  However after a few attempts I have managed to get Petalinux running and built the bootloader etc etc ...
So Linux is now running comfortably on the TE0820 for the moment booting from SDCard.
Now I need to start building FPGA logic and the RPU application.

OK sorry for the long-winded intro ....... here is the actual problem !!

Under Ubuntu I cannot get the Hardware manager to connect to the board.
USB port is connected and assigned to my Linux Virtual.
I see two devices /dev/ttyUSB0  and /dev/ttyUSB1 and the TE0820 Linux Build is communicating quite nicely on ttyUSB1
[screen /dev/ttyUSB1 115200]

From Vivado [and similar story from Vitis] ...... this is 2019.2
Xilinx Hardware Server appears to be running and connects but it does not find a target.
I tried stopping the APU boot in Uboot rather than starting the Linux file system but again no joy and yes I do close down the 'screen ......' connection as well !!

if I switch over to Win10 and try the same thing everything just fine on same board same cable same everything.

Now I suppose I could start developing code again under windows but as I have a three way thing going on here which will involve a Linux application running on the A53 it's probably going to be a lot easier to keep everything running on Ubuntu.

Any clue as to what might be happing with hw_server ????



maybe try to install JTAG drivers manually again on your Linux OS.
But VM and JTAG seldom works correctly together. This can also have trouble with your WinOS on VM on other steps when you use VM and JTAG.
For JTAG usage I would recommend to use native OS, not a VM.



OK I will try this first and update.

Not sure that I agree with your comments on VM's.
I have been running windows 7 & 10 as VM's for at least the last 8 years.
The only issue I ever came across was trying to use a USB3 port from WIN7 [which didn't have native support for USB3].
JTAG cable connected to a USB2 socket never been a problem.... used in anger !!
Same applies using it for Segger-JLINK and also Cypress and Silicon Labs debugging tools.

Admittedly Ubuntu is a new factor in this but it seems to be working fine as a TTY to the Linux running on the board.


It's a problem with VM and JTAG. I don't know why and if it's related to the OS on VM or it's a general a VM problem. It's not the first time that someone has problem with this combination.  See for example


OK Resolved .....
I did two things, not sure which one had the magic ingredient or if I really needed to do both.

SO ...

[1] re-installed cable drivers.
[2] added my user to dialout group to make sure that that I have read/write permissions to the /dev/ttyUSB* ports.   
This was done with the following command....   
    sudo usermod -a -G dialout $USER
As suggested here.

So far so good everything now appears to be working fine.

Now I have to workout how to get the RPU's to run alongside the PetaLinux.
Seems complicated so I might be back !!!


BTW regarding the links you sent me about previous problems with VM's

The first one [chcollin] most likely the problem there is that the serial ports are showing up connected to the Windows host for the VM.
You have to assign ports either to the VM or to the host you can't have both.
With VMware fusion it politely asks where you want to attached when you plug in the USB cable......     never tried VirtualBox so might be a different approach.

Second one ... not sure about but it suggests that there might have been a permissions issue. This is why I messed around with device permissions in my case.


it was only some example where people have problems with VM and JTAG.

I's good to hear that you found a solution for you. But I still would not recommend to use JTAG over VM.