Author Topic: NIOS II - Flasing the elf file  (Read 773 times)


  • Active Member
  • *
  • Posts: 17
NIOS II - Flasing the elf file
« on: February 21, 2020, 01:45:58 PM »

I am playing with my new CYC1000 board and have come across my first problem (That Google could not help me solve)

I could test a simple counter to flash the LEDs and it worked like a charm. Next, I am following the steps to implement a NIOS core to send a "Hello World" message over the JTAG UART. Everything goes well till the compilation of the C code. I can flash the fpga with the image as well. However, when I try to flash the elf file, I get the following error:

Using cable "Arrow-USB-Blaster [USB0]", device 1, instance 0x00
Pausing target processor: not responding.
Resetting and trying again: FAILED
Leaving target processor paused

I have tried it from the NIOS SDT as well as from the command line console. I did not find any unassigned pins (only clk needed to be assigned)

The clock is running at a basic 12MHz.

Is this a known problem or can anyone guide me in the right direction?



  • Active Member
  • *
  • Posts: 17
Re: NIOS II - Flasing the elf file
« Reply #1 on: February 21, 2020, 03:22:15 PM »
Hello again,

I am glad to report that I was able to find the fault and rectify it.

It turns out that my clock of 12MHz was indeed too slow compared to the JTAG clock. There was a warning about this when setting up the IP but I did not give it much of a thought back then.

I am guessing there are two ways to solve this problem and i might have taken the more complicated way.

The easier method will be to add a PLL to clock the NIOS at 50MHz or more.

My solution includes finding the current JTAG clock using the command:
jtagconfig.exe --getparam 1 JtagClock

run under the console. Returns 20M.

Setting this parameter to 4M using the command
jtagconfig.exe --setparam 1 JtagClock 4M

seems to have solved the problem.