Attention: For security reasons,please choose a user name *different* from your login name.
Also make sure to choose a secure password and change it regularly.

Main Menu

Issue with EDK 12.2 Reference design

Started by arubos, April 06, 2011, 10:48:32 AM

Previous topic - Next topic


Board: TE0320-00-EV02
Reference design:

First HW setup was prepared according to UM-TE0320.pdf
- config via USB: done
- with USBFirmwareUpgradeTool.exe: existing TE0320-00-EV0x.fwu was downloaded into the board

For verification: TE0320_API_Example.exe was used
everything was working fine
all user LEDs were lit

------- My problem: ----------

The Reference project built in EDK 12.2 is not working for me in the FPGA:

Using project in reference-TE0320-00-EDK-12-2 directory
system.xmp was XC3SD1800A-demo
system.ucf was XC3SD1800A-demo

In XPS, Click on Download Bitstream to the FPGA
Bitstream generation was SUCCESSFUL, no errors
For verification: TE0320_API_Example.exe was used
Something was not working in the FPGA
User LEDs were not lit

I tried another way:
Using original data in bit-streams directory:
TE0320-00-EV02-demo.bit was converted into FWU according to UM-TE0320.pdf
Downloaded with USBFirmwareUpgradeTool.exe
For verification: TE0320_API_Example.exe was used
Something was not working in the FPGA
User LEDs were not lit

I compared my download.bit from reference design and the original TE0320-00-EV02-demo.bit files and they are the same except date and time.

Can you help me?

Thank you.


Dear Attila,

I tried to reproduce your system as close as possible . I downloaded and tested on a TE0320-00 (1800) wtih Xilinx Platform Studio 12.2.

Quote from: arubos on April 06, 2011, 10:48:32 AM
system.ucf was XC3SD1800A-demo
You probably meant "system.ucf was XC3SD1800A", there is just one UCF for both reference applications.

I partly experienced the same problem:

  • "demo" application > "Mark to initialize BRAM" > "Download bitstream to the FPGA" button > no leds lit (wrong)
  • "bootloader" application > Mark to initialize BRAM" > "Download bitstream to the FPGA" button > leds lit (right)

This is an issue to follow up. Then I tried to debug in-cuircuit both applications: "Start XMD" button > "Start Software Debugger (gdb)" button. Both were run correctly. So please try the same and tell us if you can also do the same. We are working on the XPS 13.1 version, that will allow much more powerful and user-friendly in-circuit debugging.

Moreover, it is alway a good idea to connect a terminal to the UART port:
This will add more details when providing technical support.

- Horsa

Ales Gorkic

Dear Attila and Horsa,

Horsa, you are right.
I have checked the system.xmp.XC3SD1800A-demo
There is a problem with the demo application since it is compiled to run from the external DDR memory:
Line 47-49
ProgStart: 0x10000000  (DDR base address)
StackSize: 0x800
HeapSize: 0x800

It should be
for running the program from BRAM.

To change the setting you can also use the XPS GUI where you right click on the demo SW project "Set Compiler options" and erase the wrong settings.
I have also commited the changes to ALL TE03XX projects.

Best regards,



Dear Ales and Horsa,

Thank you for your prompt reply and solution!
I will improve my debug capability.

Thanks again.
Best Regards,
Attila Rubos