Author Topic: petalinux 2017.2 turning off DHCP on the TEBF0808 starter kit?  (Read 1765 times)

Aaron

  • Active Member
  • *
  • Posts: 11
I'm using the TEBF0808 with 2017.2, and I have a network issue:

By default, this build enables DHCP and ipv6.  I'd like to turn that into a static ipv4 address (disable ipv6, set static ip).  Could someone offer advice on how to do this?

So far, I tried turning off DHCP and making the ip address static in the petalinux-config menu, under Subsystem AUTO Hardware Settings -> Ethernet Settings.

I've also tried adding an interfaces file as demonstrated in this Xilinx AR: https://www.xilinx.com/support/answers/69119.html

However, these were ignored.  Booting the image yields a petalinux installation that does not have a static ip address, as far as I can tell, this looks the same as before I made my change:

Code: [Select]
root@petalinux:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0A:35:00:22:01
          inet6 addr: fe80::20a:35ff:fe00:2201%4879704/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:156 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:49632 (48.4 KiB)
          Interrupt:23

To disable ipv6, so far I've tried adding a sysctl init command (at some point in the past when I was trying 2018.2).  I tried the equivalent of an init script that did "sysctl -w net.ipv6.conf.all.disable_ipv6=1" and "sysctl -w net.ipv6.conf.default.disable_ipv6=1", but at that time, the system became unbootable (never made it past "bootconsole [cdns0] disabled" (or something similar)).  My thought was that maybe I need to do this in the network driver.

« Last Edit: April 02, 2019, 08:22:58 PM by Aaron »

JH

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1605
Re: petalinux 2017.2 turning off DHCP on the TEBF0808 starter kit?
« Reply #1 on: April 03, 2019, 11:02:10 AM »

Aaron

  • Active Member
  • *
  • Posts: 11
Re: petalinux 2017.2 turning off DHCP on the TEBF0808 starter kit?
« Reply #2 on: April 09, 2019, 07:52:01 PM »
Things are working now.  The petalinux procedure for initializing the network parameters require creating a bitbake recipe for init-ifupdown to populate the /etc/interfaces file on the target.  For some reason, this wasn't working for me, but now it is.  This might be because I cleaned out the meta-plnx-generated directory that had residual build information from a 2017.3 build for the ZCU102.