Community > Arrow USB Programmer2

jtag problem on new TEI0003 CYC1000 board

(1/2) > >>

I recently purchased the TEI0003 cyclone10-LP board from trenz.  I was able to use the jtag to load the demo LED sequencer into the FPGA and the Flash on Monday but coming back to it on Wednesday I wasn't even able to discover the jtag chain and I don't see any traffic on TCK or TDI J4 jumper pins.  Is there something I could have done to break the USB to jtag link?   


did you installed some other drivers during this time? Or OS Updates?
Did you try to change something on the FTDI of the module?
Can you try out another USB connector on your PC and maybe other USB Cable?

Which OS did you use?
For WinOS there is a trouble shoot guide and a diagnose tool available:

* you try out  this please?

For Linux are only general notes available:


On Monday I received it and used the demo to test it.  It failed when I attempted to load my own design on Wednesday.  I'm not aware of any significant changes to the computer in that time. It immediately failed with a "209040 Can't access JTAG chain" error message.   From searching on this error message, this error seems to be often associated with physical issues with the jtag connection. I then wesnt back and attempted to replicate the steps I did to program the demo on Monday and received the same error.  I checked the troubleshooter and ran the diagnostic.  I found no problems and the diagnostic program found no problems. 

When I deliberately disconnected the USB and attempted to program the unit a different error message "209037 JTAG Server can't access selected programming hardware" was displayed.  I take this to mean that the original problem is somewhere downstream from the USB cord.     

did you reduced JTAG speed on time?

So from your text, I think your use Windows, correct? Which version? Native or VM?

When did this messages appears? When you open JTAG Chain with Quartus or when you try to program?
From other forum entries "209040 Can't access JTAG chain" this appears when you try to programming, correct?

Which USB Port did you use on your PC? USB1 m USB2 or USB3? You should use USB2 or USB3. Can you try out another USB Port?

Maybe you has some power problem, because modules is supplied over USB. And when you start programming, it needs more power for short time.

Can you get access with JTAG chain debugger?



I acquired a second TEI0003 unit today and programming the new unit works fine so far (but then it initially worked fine with the first board as well). I don't think I was at all rough with the first board. I was pretty careful with the ESD.

re your questions: 

win10 native quartus prime lite 18.1.  I tried different USB ports.
Had problem on programming (as described)and on autodetect.

when I attempted to autodetect the jtag chain it said it was "unable to scan device chain" and offered to open jtag chain debugger.  When I click the Test jtag chain button in the debugger it reports:"Error: JTAG chain problem detected Error:No Device detected".  I don't know the jtag debugger so going deeper into it would require some reading. I tried my best guess for how to do something (some sign of life) since at this stage the warning about damaging the device is a bit moot but when I attempted to run a test, the debugger froze and eventually crashed.   I don't know if that has anything to do with the fundamental problem or it is just my using the  debugger improperly.

regards, Dana     



[0] Message Index

[#] Next page

Go to full version